3fbe7b67e7
Add upstream patch for xattr include fix. Also rename patches to git naming convention. Fixes: http://autobuild.buildroot.net/results/2ef/2efb25356bc87ba0e1be08214eaa28ac064ad6c3/ Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
31 lines
981 B
Diff
31 lines
981 B
Diff
libcap: split install into install-shared/install-static
|
|
|
|
In order to support static only builds, split the install target into
|
|
install-shared and install-static targets.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
|
|
Index: b/libcap/Makefile
|
|
===================================================================
|
|
--- a/libcap/Makefile
|
|
+++ b/libcap/Makefile
|
|
@@ -60,11 +60,17 @@
|
|
cap_text.o: cap_text.c $(USE_GPERF_OUTPUT) $(INCLS)
|
|
$(CC) $(CFLAGS) $(IPATH) $(INCLUDE_GPERF_OUTPUT) -c $< -o $@
|
|
|
|
-install: all
|
|
+install: install-shared install-static
|
|
+
|
|
+install-common:
|
|
mkdir -p -m 0755 $(INCDIR)/sys
|
|
install -m 0644 include/sys/capability.h $(INCDIR)/sys
|
|
mkdir -p -m 0755 $(LIBDIR)
|
|
+
|
|
+install-static: install-common
|
|
install -m 0644 $(STALIBNAME) $(LIBDIR)/$(STALIBNAME)
|
|
+
|
|
+install-shared: install-common
|
|
install -m 0755 $(MINLIBNAME) $(LIBDIR)/$(MINLIBNAME)
|
|
ln -sf $(MINLIBNAME) $(LIBDIR)/$(MAJLIBNAME)
|
|
ln -sf $(MAJLIBNAME) $(LIBDIR)/$(LIBNAME)
|