c24c874810
Note that we don't use completely sequential numbers, because patches below 100 are used to address cross-compilation issues in Python 3, while patches above 100 are used to make more Python 3 modules configurable. [Thomas: fixup commit log.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
83 lines
2.5 KiB
Diff
83 lines
2.5 KiB
Diff
Add an option to disable IDLE
|
|
|
|
IDLE is an IDE embedded into python, written using Tk, so it doesn't make
|
|
much sense to have it into our build.
|
|
|
|
Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com>
|
|
|
|
---
|
|
Makefile.pre.in | 8 +++++++-
|
|
configure.ac | 6 ++++++
|
|
setup.py | 4 +++-
|
|
3 files changed, 16 insertions(+), 2 deletions(-)
|
|
|
|
Index: b/Makefile.pre.in
|
|
===================================================================
|
|
--- a/Makefile.pre.in
|
|
+++ b/Makefile.pre.in
|
|
@@ -1100,7 +1100,9 @@
|
|
-rm -f $(DESTDIR)$(LIBPC)/python3.pc
|
|
(cd $(DESTDIR)$(LIBPC); $(LN) -s python-$(VERSION).pc python3.pc)
|
|
-rm -f $(DESTDIR)$(BINDIR)/idle3
|
|
+ifeq (@IDLE@,yes)
|
|
(cd $(DESTDIR)$(BINDIR); $(LN) -s idle$(VERSION) idle3)
|
|
+endif
|
|
-rm -f $(DESTDIR)$(BINDIR)/pydoc3
|
|
ifeq (@PYDOC@,yes)
|
|
(cd $(DESTDIR)$(BINDIR); $(LN) -s pydoc$(VERSION) pydoc3)
|
|
@@ -1148,7 +1150,6 @@
|
|
html json http dbm xmlrpc \
|
|
logging csv wsgiref urllib \
|
|
ctypes ctypes/macholib \
|
|
- idlelib idlelib/Icons \
|
|
distutils distutils/command \
|
|
importlib \
|
|
turtledemo \
|
|
@@ -1225,6 +1226,10 @@
|
|
LIBSUBDIRS += $(XMLLIBSUBDIRS)
|
|
endif
|
|
|
|
+ifeq (@IDLE@,yes)
|
|
+LIBSUBDIRS += idlelib idlelib/Icons
|
|
+endif
|
|
+
|
|
ifeq (@TEST_MODULES@,yes)
|
|
LIBSUBDIRS += $(TESTSUBDIRS)
|
|
endif
|
|
Index: b/configure.ac
|
|
===================================================================
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -2743,6 +2743,12 @@
|
|
AS_HELP_STRING([--disable-lib2to3], [disable lib2to3]),
|
|
[ LIB2TO3="${enableval}" ], [ LIB2TO3=yes ])
|
|
|
|
+AC_SUBST(IDLE)
|
|
+
|
|
+AC_ARG_ENABLE(idle3,
|
|
+ AS_HELP_STRING([--disable-idle3], [disable idle3 IDE]),
|
|
+ [ IDLE="${enableval}" ], [ IDLE=yes ])
|
|
+
|
|
# Check for enable-ipv6
|
|
AH_TEMPLATE(ENABLE_IPV6, [Define if --enable-ipv6 is specified])
|
|
AC_MSG_CHECKING([if --enable-ipv6 is specified])
|
|
Index: b/setup.py
|
|
===================================================================
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -2213,11 +2213,13 @@
|
|
import warnings
|
|
warnings.filterwarnings("ignore",category=DeprecationWarning)
|
|
|
|
- scripts = ['Tools/scripts/idle3', 'Lib/smtpd.py']
|
|
+ scripts = ['Lib/smtpd.py']
|
|
if not '--disable-pydoc' in sysconfig.get_config_var("CONFIG_ARGS"):
|
|
scripts += [ 'Tools/scripts/pydoc3' ]
|
|
if not '--disable-lib2to3' in sysconfig.get_config_var("CONFIG_ARGS"):
|
|
scripts += [ 'Tools/scripts/2to3' ]
|
|
+ if not '--disable-idle3' in sysconfig.get_config_var("CONFIG_ARGS"):
|
|
+ scripts += [ 'Tools/scripts/idle3' ]
|
|
|
|
setup(# PyPI Metadata (PEP 301)
|
|
name = "Python",
|