kumquat-buildroot/package/uacme/0001-Fix-cross-compilation.patch
Fabrice Fontaine 3e48306a43 package/uacme: fix build
Fix the following build failure raised since bump to version 1.7.5 in
commit b7ee5f3b0e and
fe826f4b19:

checking if mmap(MAP_ANON|MAP_SHARED) works... configure: error: in `/home/autobuild/autobuild/instance-9/output-1/build/uacme-1.7.5':
configure: error: cannot run test program while cross compiling

Fixes: b7ee5f3b0e
 - http://autobuild.buildroot.org/results/9715ade98f4894c07b640d151daa41813d2bec3a

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[yann.morin.1998@free.fr: reference patch in comment]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
2024-02-20 21:43:00 +01:00

30 lines
1.3 KiB
Diff

From cdf63e24dc475a558400c68714e32d32904e4c57 Mon Sep 17 00:00:00 2001
From: Nicola Di Lieto <nicola.dilieto@gmail.com>
Date: Tue, 20 Feb 2024 01:05:00 +0100
Subject: [PATCH] Fix cross compilation
Commit fe826f4b1931ae508047d8b2693b5b6ac2cb21fd broke cross compilation
Closes https://github.com/ndilieto/uacme/issues/79
Upstream: https://github.com/ndilieto/uacme/commit/cdf63e24dc475a558400c68714e32d32904e4c57
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
configure.ac | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
index 77d1230..3bec75b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -355,7 +355,8 @@ if test "x$OPT_UALPN" != "xno"; then
AC_DEFINE(HAVE_MAP_DEVZERO, 1, [if mmap("/dev/zero", MAP_SHARED) works])
AC_MSG_RESULT([yes]),
AC_MSG_RESULT([no])
- AC_MSG_ERROR([ualpn requires MAP_ANON or mmap("/dev/zero", MAP_SHARED)])),
+ AC_MSG_ERROR([ualpn requires MAP_ANON or mmap("/dev/zero", MAP_SHARED)]))
+ ], [
AC_COMPILE_IFELSE([AC_LANG_SOURCE([#include <sys/mman.h>
int main() {return mmap(0, 4096, PROT_READ|PROT_WRITE,
MAP_ANON|MAP_SHARED, -1, 0) == MAP_FAILED;}])],