kumquat-buildroot/package/usb_modeswitch/0001-fix-systemd-detection.patch
Sol Bekic c6b746e6fc package/usb_modeswitch: fix installation of systemd unit file
The upstream Makefile failed to detect systemd being present in some (maybe all)
builds, resulting in the unit file not being installed. Without the unit file,
the udev rules in usb_modeswitch-data don't work as expected (no modeswitch is
performed).

This commit adds a patch that modifies the Makefile to include
'$(PREFIX)/bin/systemctl' in the list of paths checked, which makes the
installation phase work as intended. I will also submit this patch upstream.

Signed-off-by: Sol Bekic <s+removethis@s-ol.nu>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
2022-05-14 23:52:22 +02:00

19 lines
885 B
Diff

Modify the Makefile to include '$(PREFIX)/bin/systemctl' in the list of paths.
This makes the udev intgeration work as intended when using systemd.
Signed-off-by: Sol Bekic <s+removethis@s-ol.nu>
diff --git a/Makefile b/Makefile
index 22bd0e0..72321a4 100755
--- a/Makefile
+++ b/Makefile
@@ -62,7 +62,7 @@
install -D --mode=755 usb_modeswitch_dispatcher $(SBINDIR)/usb_modeswitch_dispatcher
install -d $(DESTDIR)/var/lib/usb_modeswitch
test -d $(UPSDIR) -a -e /sbin/initctl && install --mode=644 usb-modeswitch-upstart.conf $(UPSDIR) || test 1
- test -d $(SYSDIR) -a \( -e /usr/bin/systemctl -o -e /bin/systemctl \) && install --mode=644 usb_modeswitch@.service $(SYSDIR) || test 1
+ test -d $(SYSDIR) -a \( -e /usr/bin/systemctl -o -e /bin/systemctl -o -e $(PREFIX)/bin/systemctl \) && install --mode=644 usb_modeswitch@.service $(SYSDIR) || test 1
install: install-script