157dc65fb7
The version bump doesn't inherently fix the security issues, however the added CVE patches do, which fix: CVE-2016-2147 - out of bounds write (heap) due to integer underflow in udhcpc. CVE-2016-2148 - heap-based buffer overflow in OPTION_6RD parsing. Drop patches that are upstream as well. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
29 lines
963 B
Diff
29 lines
963 B
Diff
From 67eb23d2be8aba3c474dac81a15b0fa11e5847b7 Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Date: Mon, 25 Nov 2013 22:51:53 +0100
|
|
Subject: [PATCH] Makefile.flags: strip non -l arguments returned by pkg-config
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
---
|
|
Makefile.flags | 4 +++-
|
|
1 file changed, 3 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/Makefile.flags b/Makefile.flags
|
|
index 307afa7..885e323 100644
|
|
--- a/Makefile.flags
|
|
+++ b/Makefile.flags
|
|
@@ -141,7 +141,9 @@ ifeq ($(CONFIG_SELINUX),y)
|
|
SELINUX_PC_MODULES = libselinux libsepol
|
|
$(eval $(call pkg_check_modules,SELINUX,$(SELINUX_PC_MODULES)))
|
|
CPPFLAGS += $(SELINUX_CFLAGS)
|
|
-LDLIBS += $(if $(SELINUX_LIBS),$(SELINUX_LIBS:-l%=%),$(SELINUX_PC_MODULES:lib%=%))
|
|
+LDLIBS += $(if $(SELINUX_LIBS),\
|
|
+ $(patsubst -l%,%,$(filter -l%,$(SELINUX_LIBS))),\
|
|
+ $(SELINUX_PC_MODULES:lib%=%))
|
|
endif
|
|
|
|
ifeq ($(CONFIG_EFENCE),y)
|
|
--
|
|
1.8.1.2
|
|
|