kumquat-buildroot/package/mesa3d-demos/0001-demos-optional-gl.patch
Bernd Kuhls 6bf44ee4ce package/mesa3d-demos: bump version to 8.3.0
Currently buildroot lacks glut support so add configure options to
disable glut support, also disable osmesa support because it also
depends on glut.

Re-numbered and rebased 0001-demos-optional-gl.patch

Removed patches:
- 0001-demos-non-mesa-impl.patch
All files related to this patch have been removed upstream:
http://cgit.freedesktop.org/mesa/demos/commit/?id=74443c6ee79f3251f643ea05e94df58183e37d0d

- 0003-demos-x11-fix.patch
Applied upstream:
http://cgit.freedesktop.org/mesa/demos/commit/?id=6f7ad3f242943242021d1c42c6ed6933b76137fd

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2015-12-13 14:32:56 +01:00

78 lines
2.3 KiB
Diff

This patches makes opengl an optional component.
Signed-off-by: Spenser Gilliland <spenser@gillilanding.com>
---
Index: mesa3d-demos-8.1.0/configure.ac
===================================================================
--- mesa3d-demos-8.1.0.orig/configure.ac
+++ mesa3d-demos-8.1.0/configure.ac
@@ -51,6 +51,14 @@
ACLOCAL="aclocal -I/other/macro/dir" before running autoreconf.])])
PKG_PROG_PKG_CONFIG()
+AC_ARG_ENABLE([gl],
+ [AS_HELP_STRING([--enable-gl],
+ [enable GL library @<:@default=no@:>@])],
+ [gl_enabled="$enableval"],
+ [gl_enabled=auto])
+
+if test "x$gl_enabled" != "xno"; then
+
dnl Get the pkg-config definitions for libGL. We include a fallback
dnl path for GL implementation that don't provide a .pc file
PKG_CHECK_MODULES(GL, [gl], [], [
@@ -113,6 +121,8 @@
DEMO_CFLAGS="$DEMO_CFLAGS $GLU_CFLAGS"
DEMO_LIBS="$DEMO_LIBS $GLU_LIBS"
+fi
+
AC_ARG_ENABLE([egl],
[AS_HELP_STRING([--enable-egl],
[enable EGL library @<:@default=auto@:>@])],
@@ -303,7 +313,7 @@
AC_SUBST([WAYLAND_CFLAGS])
AC_SUBST([WAYLAND_LIBS])
-
+AM_CONDITIONAL(HAVE_GL, test "x$gl_enabled" = "xyes")
AM_CONDITIONAL(HAVE_EGL, test "x$egl_enabled" = "xyes")
AM_CONDITIONAL(HAVE_GLESV1, test "x$glesv1_enabled" = "xyes")
AM_CONDITIONAL(HAVE_GLESV2, test "x$glesv2_enabled" = "xyes")
Index: mesa3d-demos-8.1.0/src/egl/opengl/Makefile.am
===================================================================
--- mesa3d-demos-8.1.0.orig/src/egl/opengl/Makefile.am
+++ mesa3d-demos-8.1.0/src/egl/opengl/Makefile.am
@@ -50,12 +50,14 @@
endif
if HAVE_EGL
+if HAVE_GL
noinst_PROGRAMS = \
eglinfo \
peglgears \
$(EGL_DRM_DEMOS) \
$(EGL_X11_DEMOS)
endif
+endif
egltri_x11_SOURCES = egltri.c
eglgears_x11_SOURCES = eglgears.c
Index: mesa3d-demos-8.1.0/src/util/Makefile.am
===================================================================
--- mesa3d-demos-8.1.0.orig/src/util/Makefile.am
+++ mesa3d-demos-8.1.0/src/util/Makefile.am
@@ -27,7 +27,9 @@ AM_CFLAGS = \
AM_LDFLAGS = \
$(DEMO_LIBS)
+if HAVE_GL
noinst_LTLIBRARIES = libutil.la
+endif
if HAVE_GLUT
AM_CFLAGS += \
diff -uNr mesa-demos-8.3.0.org/configure.ac mesa-demos-8.3.0/configure.ac
--- mesa-demos-8.3.0.org/configure.ac 2015-12-09 22:06:44.000000000 +0100
+++ mesa-demos-8.3.0/configure.ac 2015-12-12 17:06:10.484295811 +0100