3cd8023c73
boost_python library is named boost_python3, if boost is built under Python3 environment. The patch fixes setup.py accordingly. Fixes: http://autobuild.buildroot.net/results/975/97533965180436c2f7a99de07fdc360ef57f84b0 http://autobuild.buildroot.net/results/b49/b49de32704f0f7ce5a610cf4363c6dcc2d8bafa1 http://autobuild.buildroot.net/results/e26/e26b4b9b486c582fb55826817a3428569968320f Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
41 lines
1.1 KiB
Diff
41 lines
1.1 KiB
Diff
From 3bc4b9c0d60a735b1d63e52f74492ace39f02824 Mon Sep 17 00:00:00 2001
|
|
From: Yegor Yefremov <yegorslists@googlemail.com>
|
|
Date: Thu, 27 Jul 2017 09:46:07 +0200
|
|
Subject: [PATCH] Determine boost_python name depending on current Python
|
|
version
|
|
|
|
Python2 requires boost_python and Python3 requires boost_python3.
|
|
|
|
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
|
|
---
|
|
setup.py | 6 +++++-
|
|
1 file changed, 5 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/setup.py b/setup.py
|
|
index fdf5c27..4b38569 100644
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -3,6 +3,10 @@
|
|
from setuptools import setup, find_packages, Extension
|
|
import sys, os
|
|
|
|
+boostlib = "boost_python3"
|
|
+if sys.version_info < (3, 0):
|
|
+ boostlib = "boost_python"
|
|
+
|
|
setup(
|
|
name = 'pylibconfig',
|
|
description = "libconfig bindings for Python",
|
|
@@ -19,7 +23,7 @@ setup(
|
|
Extension(
|
|
"pylibconfig",
|
|
["src/pylibconfig.cc"],
|
|
- libraries=["boost_python", "config++"]
|
|
+ libraries=[boostlib, "config++"]
|
|
#include_dirs=includes,
|
|
#extra_link_args=lflags
|
|
)
|
|
--
|
|
2.11.0
|
|
|