e889a1c9e9
Fix the following openssl static build raised since commit80fa5672da
: /home/buildroot/autobuild/instance-0/output-1/host/lib/gcc/aarch64_be-buildroot-linux-uclibc/12.3.0/../../../../aarch64_be-buildroot-linux-uclibc/bin/ld: /home/buildroot/autobuild/instance-0/output-1/host/aarch64_be-buildroot-linux-uclibc/sysroot/lib/../lib64/libcrypto.a(libcrypto-lib-c_zlib.o): in function `zlib_oneshot_expand_block': c_zlib.c:(.text+0xaec): undefined reference to `uncompress' Commitb9a062b354
can also be reverted as pkg-config will also retrieve -latomic to avoid the following build failure: /home/autobuild/autobuild/instance-1/output-1/host/lib/gcc/sparc-buildroot-linux-uclibc/10.4.0/../../../../sparc-buildroot-linux-uclibc/bin/ld: /home/autobuild/autobuild/instance-1/output-1/host/sparc-buildroot-linux-uclibc/sysroot/usr/lib/libcrypto.a(threads_pthread.o): in function `CRYPTO_atomic_add': threads_pthread.c:(.text+0x208): undefined reference to `__atomic_is_lock_free' RSYNC_POST_CONFIGURE_HOOKS must be added to call reconfigure and avoid the following build failure after autoreconf: autoconf -o configure.sh autoheader && touch config.h.in configure.sh has CHANGED. config.h.in is unchanged. You may need to run: make reconfigure Fixes: - http://autobuild.buildroot.org/results/6c1636f7556e7370a4c9f6d02c63cf3e20dc985c - http://autobuild.buildroot.org/results/49abbaa1eab94b248bff434b40728065d687e278 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
29 lines
1.2 KiB
Diff
29 lines
1.2 KiB
Diff
From 556a2c5bc2f6244f140a96302d4df92cfc25af8b Mon Sep 17 00:00:00 2001
|
|
From: Wayne Davison <wayne@opencoder.net>
|
|
Date: Tue, 25 Oct 2022 21:55:53 -0700
|
|
Subject: [PATCH] Check for EVP_MD_CTX_copy in crypto lib instead of MD5_Init.
|
|
|
|
Upstream: https://github.com/WayneD/rsync/commit/556a2c5bc2f6244f140a96302d4df92cfc25af8b
|
|
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
---
|
|
configure.ac | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index a2c99558..ccad7f13 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -432,10 +432,10 @@ AH_TEMPLATE([USE_OPENSSL],
|
|
if test x"$enable_openssl" != x"no"; then
|
|
if test x"$ac_cv_header_openssl_md4_h" = x"yes" && test x"$ac_cv_header_openssl_md5_h" = x"yes"; then
|
|
AC_MSG_RESULT(yes)
|
|
- AC_SEARCH_LIBS(MD5_Init, crypto,
|
|
+ AC_SEARCH_LIBS(EVP_MD_CTX_copy, crypto,
|
|
[AC_DEFINE(USE_OPENSSL)
|
|
enable_openssl=yes],
|
|
- [err_msg="$err_msg$nl- Failed to find MD5_Init function in openssl crypto lib.";
|
|
+ [err_msg="$err_msg$nl- Failed to find EVP_MD_CTX_copy function in openssl crypto lib.";
|
|
no_lib="$no_lib openssl"])
|
|
else
|
|
AC_MSG_RESULT(no)
|