e8fb454db6
[Thomas: - remove the patch from Matthew Weber that did a lot of changes that were not needed: the CFLAGS would not get overridden by Buildroot ones if the Buildroot TARGET_CONFIGURE_OPTS is passed on the left hand-side of make, and the SULOGINLIBS hack needs to be replaced by a proper handling of the libcrypt detection. - added a patch that changes the libcrypt detection logic to accept a SYSROOT variable. Instead of search for /usr/lib/libcrypt.a, it search for $(SYSROOT)/usr/lib/libcrypt.a. This avoids the need for overriding SULOGINLIBS. - don't modify TARGET_CONFIGURE_OPTS in sysvinit.mk, this is completely forbidden and broken. - don't pass ROOT= since we don't use 'make install' anyway.] Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com> Reviewed-by: Samuel Martin <s.martin49@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
18 lines
451 B
Diff
18 lines
451 B
Diff
Make the libcrypt test somewhat cross-compilation compliant
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
|
|
Index: b/src/Makefile
|
|
===================================================================
|
|
--- a/src/Makefile
|
|
+++ b/src/Makefile
|
|
@@ -78,7 +78,7 @@
|
|
endif
|
|
|
|
# Additional libs for GNU libc.
|
|
-ifneq ($(wildcard /usr/lib*/libcrypt.a),)
|
|
+ifneq ($(wildcard $(SYSROOT)/usr/lib*/libcrypt.a),)
|
|
SULOGINLIBS += -lcrypt
|
|
endif
|
|
|