819cfcf7aa
Globally change Adam Duskett's email address to aduskett@gmail.com. Note that one or two of the patches may have been applied upstream with the old email address, but in that case those patches will anyway be removed when bumping. Signed-off-by: Adam Duskett <Aduskett@gmail.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
57 lines
2.2 KiB
Diff
57 lines
2.2 KiB
Diff
From a221304344b3f9db7e86d928cf97d77542bcf456 Mon Sep 17 00:00:00 2001
|
|
From: Adam Duskett <aduskett@gmail.com>
|
|
Date: Mon, 9 Oct 2017 16:47:19 -0400
|
|
Subject: [PATCH] Add PREFIX to host paths
|
|
|
|
Updates the remaining hardcoded host paths used in the build to be
|
|
prefixed with a PREFIX path to allow cross compilation.
|
|
|
|
Updated to work with version 2.5
|
|
|
|
Signed-off-by: Clayton Shotwell <clayton.shotwell@rockwellcollins.com>
|
|
Signed-off-by: Niranjan Reddy <niranjan.reddy@rockwellcollins.com>
|
|
Signed-off-by: Adam Duskett <aduskett@gmail.com>
|
|
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
[Update for 2.8]
|
|
---
|
|
load_policy/Makefile | 2 +-
|
|
newrole/Makefile | 6 +++---
|
|
run_init/Makefile | 6 +++---
|
|
3 files changed, 7 insertions(+), 7 deletions(-)
|
|
|
|
diff --git a/newrole/Makefile b/newrole/Makefile
|
|
index 196af92..896708f 100644
|
|
--- a/newrole/Makefile
|
|
+++ b/newrole/Makefile
|
|
@@ -3,9 +3,9 @@ PREFIX ?= $(DESTDIR)/usr
|
|
BINDIR ?= $(PREFIX)/bin
|
|
MANDIR ?= $(PREFIX)/share/man
|
|
ETCDIR ?= /etc
|
|
LOCALEDIR = $(DESTDIR)$(PREFIX)/share/locale
|
|
-PAMH ?= $(shell test -f /usr/include/security/pam_appl.h && echo y)
|
|
-AUDITH ?= $(shell test -f /usr/include/libaudit.h && echo y)
|
|
+PAMH ?= $(shell test -f $(DESTDIR)$(PREFIX)/include/security/pam_appl.h && echo y)
|
|
+AUDITH ?= $(shell test -f $(DESTDIR)$(PREFIX)/include/libaudit.h && echo y)
|
|
# Enable capabilities to permit newrole to generate audit records.
|
|
# This will make newrole a setuid root program.
|
|
# The capabilities used are: CAP_AUDIT_WRITE.
|
|
diff --git a/run_init/Makefile b/run_init/Makefile
|
|
index 921f0b0..e1566fc 100644
|
|
--- a/run_init/Makefile
|
|
+++ b/run_init/Makefile
|
|
@@ -4,9 +4,9 @@ PREFIX ?= $(DESTDIR)/usr
|
|
SBINDIR ?= $(PREFIX)/sbin
|
|
MANDIR ?= $(PREFIX)/share/man
|
|
ETCDIR ?= /etc
|
|
LOCALEDIR ?= $(DESTDIR)$(PREFIX)/share/locale
|
|
-PAMH ?= $(shell test -f /usr/include/security/pam_appl.h && echo y)
|
|
-AUDITH ?= $(shell test -f /usr/include/libaudit.h && echo y)
|
|
+PAMH ?= $(shell test -f $(DESTDIR)$(PREFIX)/include/security/pam_appl.h && echo y)
|
|
+AUDITH ?= $(shell test -f $(DESTDIR)$(PREFIX)/include/libaudit.h && echo y)
|
|
|
|
CFLAGS ?= -Werror -Wall -W
|
|
override CFLAGS += -DUSE_NLS -DLOCALEDIR="\"$(LOCALEDIR)\"" -DPACKAGE="\"policycoreutils\""
|
|
--
|
|
2.13.6
|
|
|