5c952178b7
libpagekite is a C implementation of the backend of the PageKite relay protocol. It allows external access to embedded devices without public IP address. There is a bundled version of libev but we prefer to use the global libev library. Although the configure script has a --without-openssl option, it doesn't actually build without openssl. Patch 0001-configure.ac-fix-handling-of-with.patch is needed because we want to explicitly pass --with and --without options, even if they are the default. The way the AC_ARG_WITH macros were used, --with and --without both had the effect of enabling the option. Patch 0002-configure.ac-use-AS_HELP_STRING-for-with-openssl.patch is not needed for Buildroot, but it is part of the same upstream PR and would generate a conflict for the next patch. Patch 0003-configure.ac-use-pkg-config-for-openssl.patch is needed to pass -lz (needed by openssl) in static compilation. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Reviewed-by: Romain Naour <romain.naour@smile.fr> [Thomas: - As noticed by Romain Naour, fix the prompt of the package in the Config.in - Add entry to DEVELOPERS file - Drop the dependency on BR2_bfin, since this architecture has been dropped from Buildroot.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
29 lines
906 B
Diff
29 lines
906 B
Diff
From cb20efae0e2ca86dd48c603b61d9c20225ebcd3d Mon Sep 17 00:00:00 2001
|
|
From: "Arnout Vandecappelle (Essensium/Mind)" <arnout@mind.be>
|
|
Date: Fri, 16 Feb 2018 12:06:28 +0100
|
|
Subject: [PATCH] configure.ac: use AS_HELP_STRING for --with-openssl
|
|
|
|
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
|
|
---
|
|
configure.ac | 4 +++-
|
|
1 file changed, 3 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 130752a..4874c0b 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -17,7 +17,9 @@ use_openssl="yes"
|
|
use_libev="yes"
|
|
|
|
specialssldir=""
|
|
-AC_ARG_WITH(openssl,[ --with-openssl=DIR Use optional openssl libs and includes from [DIR]/lib/ and [DIR]/include/openssl/],
|
|
+AC_ARG_WITH(openssl,
|
|
+ [AS_HELP_STRING([--with-openssl=DIR],
|
|
+ [Use optional openssl libs and includes from [DIR]/lib/ and [DIR]/include/openssl/])],
|
|
[ case "$with_openssl" in
|
|
yes)
|
|
;;
|
|
--
|
|
2.15.1
|
|
|