4102db0f7a
Changes include: - Change the package type to meson, as autoconf is no longer supported. - Add 0002-add-option-to-build-tests.patch Upstream won't build tests when cross-compiling. However; this means still building the tests during a host build. Building the tests causes build failures on older distributions such as CentOS 6 and Debian 7 because of the command `objcopy --add-symbol` is used when building the test "test_resources2," which is not available with the older version of objcopy provided by the distributions. - Add 0003-remove-cpp-requirement.patch: C++ is not needed when just compiling. The inclusion of C++ in meson.build is to ensure libglib doesn't accidentally use C++ reserved keywords in public headers. Because tests aren't being compiled, there is no need for C++ as a requirement. (https://gitlab.gnome.org/GNOME/glib/issues/1748) - Add 0004-Add-Wno-format-nonliteral-to-compiler-arguments.patch: This prevents a false error when compiling against older gcc versions. (https://gitlab.gnome.org/GNOME/glib/issues/1744) - Remove 0004-Do-not-hardcode-python-path-into-various-tools.patch: The switch to meson makes this obsolete. - Remove LIBGLIB2_AUTORECONF = YES from libglib2.mk: Now that libglib2 is a meson package, there is no need for AUTORECONF. - Remove LIBGLIB2_INSTALL_STAGING_OPTS from libglib2.mk: Meson resolves these correctly. - Add LIBGLIB2_REMOVE_BINDIR_PREFIX_FROM_PC_FILE in libglib2.mk: Newer versions of libglib2 prefix glib-genmarshal, gobject-query, and glib-mkenums with ${bindir}. Unfortunately, this will resolve to the host systems /bin/ directory, which will cause compilation issues if the host does not have these programs. By removing the ${bindir}/ prefix, these programs are resolved in PATH instead. Signed-off-by: Adam Duskett <Aduskett@gmail.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
33 lines
1.0 KiB
Diff
33 lines
1.0 KiB
Diff
From d5c628a6179b99705fa05ab87437321b132c81bc Mon Sep 17 00:00:00 2001
|
|
From: Brendan Heading <brendanheading@gmail.com>
|
|
Date: Wed, 21 Jun 2017 16:36:15 -0400
|
|
Subject: [PATCH] Fix compile time atomic detection
|
|
|
|
Improved compile-time detection of atomic support in the compiler.
|
|
|
|
Upstream-Status: Merged
|
|
See : https://gitlab.gnome.org/GNOME/glib/issues/1063
|
|
|
|
Signed-off-by: Brendan Heading <brendanheading@gmail.com>
|
|
Signed-off-by: Adam Duskett <aduskett@codeblue.com>
|
|
---
|
|
glib/gthread-posix.c | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/glib/gthread-posix.c b/glib/gthread-posix.c
|
|
index 71a6b7b..d09d029 100644
|
|
--- a/glib/gthread-posix.c
|
|
+++ b/glib/gthread-posix.c
|
|
@@ -65,7 +65,7 @@
|
|
#endif
|
|
|
|
/* clang defines __ATOMIC_SEQ_CST but doesn't support the GCC extension */
|
|
-#if defined(HAVE_FUTEX) && defined(__ATOMIC_SEQ_CST) && !defined(__clang__)
|
|
+#if defined(HAVE_FUTEX) && defined(__ATOMIC_SEQ_CST) && defined(__GCC_HAVE_SYNC_COMPARE_AND_SWAP_4) && !defined(__clang__)
|
|
#define USE_NATIVE_MUTEX
|
|
#endif
|
|
|
|
--
|
|
2.9.4
|
|
|