9ad1dfc2f4
Remove upstream patches and rebase all remaining patches. Disable PCIe MN library by default, it will be added in a follow up patch. Signed-off-by: Romain Naour <romain.naour@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
33 lines
1.2 KiB
Diff
33 lines
1.2 KiB
Diff
From 535f50e30afaa4fc6389273d1a5b6c20cb7cf5a4 Mon Sep 17 00:00:00 2001
|
|
From: Romain Naour <romain.naour@gmail.com>
|
|
Date: Wed, 25 May 2016 15:57:29 +0200
|
|
Subject: [PATCH] cmake: install oplk headers files
|
|
|
|
In order to be able to link a third party application
|
|
with openpowerlink libraries, we need to install the
|
|
oplk headers files related to openpowerlink stack.
|
|
|
|
Install all headers file from STACK_INCLUDE_DIR/oplk.
|
|
|
|
Signed-off-by: Romain Naour <romain.naour@gmail.com>
|
|
---
|
|
stack/CMakeLists.txt | 5 +++++
|
|
1 file changed, 5 insertions(+)
|
|
|
|
diff --git a/stack/CMakeLists.txt b/stack/CMakeLists.txt
|
|
index c6cde8c..2652858 100644
|
|
--- a/stack/CMakeLists.txt
|
|
+++ b/stack/CMakeLists.txt
|
|
@@ -104,3 +104,8 @@ ELSEIF((CMAKE_SYSTEM_NAME STREQUAL "Generic") AND (CMAKE_SYSTEM_PROCESSOR STREQU
|
|
ELSE()
|
|
MESSAGE(FATAL_ERROR "Unknown Platform and processor combination ${CMAKE_SYSTEM_NAME} and ${CMAKE_SYSTEM_PROCESSOR}!!")
|
|
ENDIF()
|
|
+
|
|
+################################################################################
|
|
+# Install oplk headers files
|
|
+################################################################################
|
|
+INSTALL(DIRECTORY ${STACK_INCLUDE_DIR}/oplk DESTINATION "include")
|
|
--
|
|
2.5.5
|
|
|