cb8b5c27b2
mkfs.axfs uses zlib, but does not have an rpath to our host dir. That's because: - we're not passing our host CFLAGS or LDFLAGS - it is forcibly setting CFLAGS in the Makefile, overriding anything specified by the user - it is not using LDFLAGS at all Add two patches so that CFLAGS and LDFLAGS from the environment are used if present. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Tested-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
20 lines
504 B
Diff
20 lines
504 B
Diff
Makefile: complement CFLAGS provided by the user
|
|
|
|
In some circumstances, the user may want to pass its own CFLAGS,
|
|
like for when the zlib headers are not located in the standard gcc
|
|
search paths.
|
|
|
|
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
|
|
|
|
diff -durN a/mkfs.axfs-legacy/Makefile b/mkfs.axfs-legacy/Makefile
|
|
--- a/mkfs.axfs-legacy/Makefile
|
|
+++ b/mkfs.axfs-legacy/Makefile
|
|
@@ -1,5 +1,5 @@
|
|
-INC = -I./
|
|
-CFLAGS = -g $(INC) -O0
|
|
+INC += -I./
|
|
+CFLAGS += -g $(INC) -O0
|
|
|
|
MKFSOBJS = mkfs.axfs.o
|
|
|