8883b8387a
The libbfd library provided by binutils unfortunately changed its API in binutils >= 2.34. This is causing some build failures at the moment on architectures such as ARC that are using a very recent binutils version, but it would also cause build failures on other architectures once they start using binutils 2.34. We fix this build issue by backporting an upstream oprofile patch. However, this patch touches configure.ac, which means we need to autoreconf, which needs another fix in configure.ac for autoreconf to succeed. With all that in place, this commit fixes: http://autobuild.buildroot.net/results/583d281c6cd2aecb65556080b379db24101ae3a8/ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
37 lines
1.1 KiB
Diff
37 lines
1.1 KiB
Diff
From ff172a49d1ca5708f45939b9b4f125cafba01db3 Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
|
|
Date: Tue, 24 Mar 2020 22:50:32 +0100
|
|
Subject: [PATCH] configure.ac: add foreign option to AM_INIT_AUTOMAKE
|
|
|
|
oprofile doesn't provide the NEWS, AUTHORS and ChangeLog file, so
|
|
autoreconf complains with:
|
|
|
|
Makefile.am: error: required file './NEWS' not found
|
|
Makefile.am: error: required file './AUTHORS' not found
|
|
Makefile.am: error: required file './ChangeLog' not found
|
|
|
|
Such errors can be avoided by passing the "foreign" option to
|
|
AM_INIT_AUTOMAKE.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
|
|
---
|
|
configure.ac | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 00e30079..87afe2b7 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -13,7 +13,7 @@ AC_PREREQ(2.13)
|
|
|
|
AC_INIT([OProfile], [1.3.0])
|
|
AC_CONFIG_SRCDIR([libop/op_config.h])
|
|
-AM_INIT_AUTOMAKE
|
|
+AM_INIT_AUTOMAKE([foreign])
|
|
AC_CONFIG_HEADERS(config.h)
|
|
|
|
AC_CHECK_DECLS([basename], [], [], [[#include <libgen.h>]])
|
|
--
|
|
2.25.1
|
|
|