9d874c9051
Rebased patch 0002 & 0003, added patch 0004 to fix build error. Switched license file to license.rst due to upstream commit https://cgit.freedesktop.org/mesa/mesa/commit/?id=4d066836e3cf307431a74eafcc8a404ce5ccea69 "No modification to the generated results have been done." Switched true/false configure option values to enabled/disabled due to upstream commit: https://cgit.freedesktop.org/mesa/mesa/commit/?id=138c003d22739b0d1e6860ed398dd511a44cde04 Remove "MESA3D_PLATFORMS += drm", this platform is now automatically selected: https://cgit.freedesktop.org/mesa/mesa/commit/?id=e00adef34a5ce485e2c9216a268ca05e89a5fc98 Remove "MESA3D_PLATFORMS += surfaceless", this platform is now automatically selected: https://cgit.freedesktop.org/mesa/mesa/commit/?id=a38e21d6683aeecb51aea4f933a77c6e7f1a6179 Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
42 lines
1.6 KiB
Diff
42 lines
1.6 KiB
Diff
From 7b46756a99aca7f27a45c3b99460f088570f6f53 Mon Sep 17 00:00:00 2001
|
|
From: Romain Naour <romain.naour@smile.fr>
|
|
Date: Wed, 17 Apr 2019 23:07:42 +0200
|
|
Subject: [PATCH] meson: Set proper value for LIBCLC_INCLUDEDIR
|
|
|
|
LIBCLC_INCLUDEDIR is the location where mesa3d OpenCL implementation
|
|
will look for OpenCL "headers" on the target, when building the OpenCL
|
|
kernels.
|
|
|
|
The value returned by pkg-config for includedir is relevant when
|
|
cross-compiling, on the build machine. But in this specific case, we
|
|
really need a value that is valid on the target.
|
|
|
|
Those headers are installed by the libclc package in /usr/share so
|
|
that they are not removed by Buildroot target-finalize logic.
|
|
|
|
Based on the patch for autotools provided by Valentin Korenblit.
|
|
|
|
Signed-off-by: Romain Naour <romain.naour@smile.fr>
|
|
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
|
[rebased for 20.02.0]
|
|
---
|
|
src/gallium/frontends/clover/meson.build | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/src/gallium/frontends/clover/meson.build b/src/gallium/frontends/clover/meson.build
|
|
index 62ac5f5278d..ecdeb39669c 100644
|
|
--- a/src/gallium/frontends/clover/meson.build
|
|
+++ b/src/gallium/frontends/clover/meson.build
|
|
@@ -63,7 +63,7 @@
|
|
clover_cpp_args,
|
|
clover_opencl_cpp_args,
|
|
clover_spirv_cpp_args,
|
|
- '-DLIBCLC_INCLUDEDIR="@0@/"'.format(dep_clc.get_pkgconfig_variable('includedir')),
|
|
+ '-DLIBCLC_INCLUDEDIR="/usr/share"',
|
|
'-DLIBCLC_LIBEXECDIR="@0@/"'.format(dep_clc.get_pkgconfig_variable('libexecdir')),
|
|
'-DCLANG_RESOURCE_DIR="@0@"'.format(join_paths(
|
|
dep_llvm.get_configtool_variable('libdir'), 'clang',
|
|
--
|
|
2.20.1
|
|
|