00599be13e
A bunch of release notes:
https://fluentbit.io/announcements/v2.1.8
https://fluentbit.io/announcements/v2.1.9
https://fluentbit.io/announcements/v2.1.10
https://fluentbit.io/announcements/v2.2.0
https://fluentbit.io/announcements/v2.2.1
https://fluentbit.io/announcements/v2.2.2
In addition:
- Dropped -fcommon fix for monkey (multiple definitions of `mk_tls_*'),
as this is fixed upstream [1].
- Added WAMR related patches.
- Rebased the patches for v2.2.2.
[1] 627422b901
.
Signed-off-by: Thomas Devoogdt <thomas@devoogdt.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
30 lines
898 B
Diff
30 lines
898 B
Diff
From 7f3fc55b734db2d28af63c393b52bc238af9f20a Mon Sep 17 00:00:00 2001
|
|
From: Thomas Devoogdt <thomas.devoogdt@barco.com>
|
|
Date: Tue, 25 Jul 2023 10:00:36 +0200
|
|
Subject: [PATCH] CMakeLists.txt: disable cxx support for librdkafka #7741
|
|
|
|
Fluent-bit is c only, so no need to compile cxx.
|
|
This fixes also a compile error in buildroot.
|
|
|
|
Upstream: https://github.com/fluent/fluent-bit/pull/7765
|
|
Signed-off-by: Thomas Devoogdt <thomas.devoogdt@barco.com>
|
|
---
|
|
CMakeLists.txt | 1 +
|
|
1 file changed, 1 insertion(+)
|
|
|
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 3229420c6..2694f189f 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -979,6 +979,7 @@ if(FLB_BACKTRACE)
|
|
endif()
|
|
|
|
if(FLB_IN_KAFKA OR FLB_OUT_KAFKA)
|
|
+ FLB_OPTION(RDKAFKA_BUILD_CXX Off)
|
|
FLB_OPTION(RDKAFKA_BUILD_STATIC On)
|
|
FLB_OPTION(RDKAFKA_BUILD_EXAMPLES Off)
|
|
FLB_OPTION(RDKAFKA_BUILD_TESTS Off)
|
|
--
|
|
2.34.1
|
|
|