a81601589e
The latest xfsprogs bump to version 4.15.1 added an optional dependency on libunistring. Make sure we build libunistring before xfsprogs. xfsprogs also added -lunistring to its make dependency. This does not work very well with cross compilation because make does not know about sysroot. Add a patch to remove this dependency. To make shared only link with libunistring work, we also need to extend the -static-libtool-libs patch to cover xfs_scrub as well. Fixes: http://autobuild.buildroot.net/results/66e/66e425b00a06f928be0951ac4196190fe88b0f62/ http://autobuild.buildroot.net/results/1cd/1cde87d1daf3c6009220ff47512794cef6a2938f/ http://autobuild.buildroot.net/results/8ba/8ba4e94cfbb8a5cbb166423a671bdbcdf535f86b/ Signed-off-by: Baruch Siach <baruch@tkos.co.il> Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
38 lines
1.2 KiB
Diff
38 lines
1.2 KiB
Diff
From 45d9ba0f01cceb75f72d157a9e4d9aaeb753a9c4 Mon Sep 17 00:00:00 2001
|
|
From: Baruch Siach <baruch@tkos.co.il>
|
|
Date: Tue, 20 Mar 2018 14:13:28 +0200
|
|
Subject: [PATCH] xfs_scrub: fix cross compile with libunistring
|
|
|
|
Commit 4bbed4ecc2a (xfs_scrub: warn about normalized Unicode name collisions)
|
|
added -lunistring to the list of the xfs_scrub dependencies. When cross
|
|
compiling make fails to find the library on the target sysroot:
|
|
|
|
make[3]: *** No rule to make target `-lunistring', needed by `xfs_scrub'. Stop.
|
|
|
|
Remove -lunistring from make dependencies of xfs_scrub to fix that.
|
|
|
|
Cc: Darrick J. Wong <darrick.wong@oracle.com>
|
|
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
|
|
---
|
|
Upstream status: https://patchwork.kernel.org/patch/10296957/
|
|
|
|
scrub/Makefile | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/scrub/Makefile b/scrub/Makefile
|
|
index 949f6fd8ba94..979603f524ff 100644
|
|
--- a/scrub/Makefile
|
|
+++ b/scrub/Makefile
|
|
@@ -69,7 +69,7 @@ vfs.c \
|
|
xfs_scrub.c
|
|
|
|
LLDLIBS += $(LIBHANDLE) $(LIBFROG) $(LIBPTHREAD) $(LIBUNISTRING) $(LIBRT)
|
|
-LTDEPENDENCIES += $(LIBHANDLE) $(LIBFROG) $(LIBUNISTRING) $(LIBRT)
|
|
+LTDEPENDENCIES += $(LIBHANDLE) $(LIBFROG) $(LIBRT)
|
|
LLDFLAGS = -static-libtool-libs
|
|
|
|
ifeq ($(HAVE_MALLINFO),yes)
|
|
--
|
|
2.16.2
|
|
|