kumquat-buildroot/package/ushare/0001-Don-t-build-po-files-if-NLS-is-disabled.patch
Fabrice Fontaine c4e1a07510 package/ushare: fix build without msgfmt
Fix the following build failure without /usr/bin/msgfmt raised since the
addition of ushare in commit 74097fd659:

make[3]: Entering directory `/home/buildroot/autobuild/run/instance-3/output-1/build/ushare-2.1/po'
/usr/bin/msgfmt -c --statistics -o fr.gmo fr.po
make[3]: /usr/bin/msgfmt: Command not found

To fix this build failure, set GMSGFMT to $(HOST_DIR)/bin/msgfmt and
don't build po files if NLS is disabled

Fixes:
 - http://autobuild.buildroot.org/results/9f6b5b8f38386135bacd2d8f6e97c1fea77bbe69

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
2021-08-26 22:53:43 +02:00

48 lines
1.0 KiB
Diff

From 977171781f5d49e61b46c0241fb67cbb7d666498 Mon Sep 17 00:00:00 2001
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Date: Sun, 22 Aug 2021 10:44:48 +0200
Subject: [PATCH] Don't build po files if NLS is disabled
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[Upstream status: https://github.com/ddugovic/uShare/pull/12]
---
Makefile | 7 +++++--
configure | 1 +
2 files changed, 6 insertions(+), 2 deletions(-)
diff --git a/Makefile b/Makefile
index ebd8f91..6686cfd 100644
--- a/Makefile
+++ b/Makefile
@@ -14,10 +14,13 @@ EXTRADIST = AUTHORS \
THANKS \
TODO \
-SUBDIRS = po \
- scripts \
+SUBDIRS = scripts \
src \
+ifeq ($(NLS),yes)
+SUBDIRS += po
+endif
+
all:
for subdir in $(SUBDIRS); do \
$(MAKE) -C $$subdir $@; \
diff --git a/configure b/configure
index 4a3efe0..162a776 100755
--- a/configure
+++ b/configure
@@ -723,6 +723,7 @@ append_config "LDFLAGS=$LDFLAGS"
append_config "INSTALL=$INSTALL"
append_config "DEBUG=$debug"
+append_config "NLS=$nls"
echolog "Creating $CONFIG_H ..."
--
2.32.0