kumquat-buildroot/package/libnl/0003-Add-musl-workaround-to-the-libc-compat.h-copy.patch
Baruch Siach c358dbd0e2 libnl: bump to version 3.2.29
Include upstream equivalent patch to fix build with older kernel headers. This
fixes build failures caused by the previous (reverted) version bump:
http://autobuild.buildroot.net/results/563/563f46e9a11f9e3b174a4e1308444f284d1b3421/
http://autobuild.buildroot.net/results/970/970463b628d9c81d5e217e92a455d2e05d0aa89e/
http://autobuild.buildroot.net/results/cee/ceea635a9d620398cbcd44ccb859b07bf6682780/

Add libc-compat.h patch to make it work for musl libc.

Add another upstream patch to fix both missing strerror_l() implementation,
and optionally missing locale support in uClibc-ng:
http://autobuild.buildroot.net/results/dce/dce5d21c27df57ac96d9302752dd1802e7a9786b/
http://autobuild.buildroot.net/results/c4b/c4b1c3f396ddd1d9242aed0953558606f929d57d/
http://autobuild.buildroot.net/results/44d/44dd3db6cdda4646fa12ccf243d6aca16bed3c90/

Add host-pkgconf dependency, since configure.ac uses PKG_CHECK_MODULES.

Add optional dependency on the 'check' package.

Cc: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2017-03-12 23:03:56 +01:00

38 lines
1.3 KiB
Diff

From be07fdbc9658de19304defa7538f219cd3f21ec0 Mon Sep 17 00:00:00 2001
From: Baruch Siach <baruch@tkos.co.il>
Date: Sun, 12 Mar 2017 08:52:20 +0200
Subject: [PATCH] Add musl workaround to the libc-compat.h copy
The libc-compat.h kernel header uses glibc specific macros to solve conflicts
with libc provided headers. This patch makes libc-compat.h work also for musl
libc.
Future rebase note: when upstream updates libc-compat.h some additional macro
definitions will be needed. See the Buildroot iproute2 patch
package/iproute2/0001-Add-the-musl-workaround-to-the-libc-compat.h-copy.patch.
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
---
Upstream status: libc-compat.h is a local copy of a kernel headers. A proper
musl fix must go to the kernel first.
---
include/linux-private/linux/libc-compat.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/include/linux-private/linux/libc-compat.h b/include/linux-private/linux/libc-compat.h
index 9bed5b6ae4d9..e2562a819464 100644
--- a/include/linux-private/linux/libc-compat.h
+++ b/include/linux-private/linux/libc-compat.h
@@ -49,7 +49,7 @@
#define _LIBC_COMPAT_H
/* We have included glibc headers... */
-#if defined(__GLIBC__)
+#if 1
/* Coordinate with glibc netinet/in.h header. */
#if defined(_NETINET_IN_H)
--
2.11.0