6a4e0314a4
With newer ARC toolchain obsolete -marcXXX were finally deperecated and so compiler throws errors now about unknown option. Solution is as simple as switching to more generic -mcu-XXX options. Which we do. Unfortunately that change in upstream U-Boot [1] happened right after v2016.09 was released an so we need to have that fix for v2016.07 which is mentioned in axs10x defconfigs and for the latest U-Boot release v2016.09 (which is selected by default if no defconfig is used). Once we deprecate either U-Boot version in U-Boot corresponding patch should be removed essentially. [1] http://git.denx.de/?p=u-boot.git;a=commit;h=7c8d81605302e7d7fdd3e7d8eb69302bddc64a2c Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: Peter Korsgaard <peter@korsgaard.com> Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> [Thomas: handle the U-Boot bump to 2016.09.01.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
40 lines
1.0 KiB
Diff
40 lines
1.0 KiB
Diff
From 7c8d81605302e7d7fdd3e7d8eb69302bddc64a2c Mon Sep 17 00:00:00 2001
|
|
From: Alexey Brodkin <abrodkin@synopsys.com>
|
|
Date: Fri, 16 Sep 2016 12:12:26 +0300
|
|
Subject: [PATCH] arc: Use -mcpu=XXX instead of obsolete -marcXXX
|
|
|
|
With newer ARC tools old way of CPU specification gets obsolete,
|
|
so we're switching to newer and more common way of setting "-mcpu".
|
|
|
|
Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com>
|
|
---
|
|
arch/arc/config.mk | 6 +++---
|
|
1 file changed, 3 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/arch/arc/config.mk b/arch/arc/config.mk
|
|
index 7c974f0..13676bd 100644
|
|
--- a/arch/arc/config.mk
|
|
+++ b/arch/arc/config.mk
|
|
@@ -31,15 +31,15 @@ CONFIG_MMU = 1
|
|
endif
|
|
|
|
ifdef CONFIG_CPU_ARC750D
|
|
-PLATFORM_CPPFLAGS += -marc700
|
|
+PLATFORM_CPPFLAGS += -mcpu=arc700
|
|
endif
|
|
|
|
ifdef CONFIG_CPU_ARC770D
|
|
-PLATFORM_CPPFLAGS += -marc700 -mlock -mswape
|
|
+PLATFORM_CPPFLAGS += -mcpu=arc700 -mlock -mswape
|
|
endif
|
|
|
|
ifdef CONFIG_CPU_ARCEM6
|
|
-PLATFORM_CPPFLAGS += -marcem
|
|
+PLATFORM_CPPFLAGS += -mcpu=arcem
|
|
endif
|
|
|
|
ifdef CONFIG_CPU_ARCHS34
|
|
--
|
|
2.7.4
|
|
|