e5e31fe92d
Refresh the patches (Thanks to Thomas Petazzoni's work) Patches removed: 0001-build-avoid-AM_CONDITIONAL-in-conditional-execution.patch 0004-fix-build-with-uClibc.patch 0004-fix-build-with-uClibc.patch 0005-Allow-usage-of-getrpcbynumber-when-getrpcbynumber_r-.patch 0007-sockaddr-h-needs-stddef-h-for-NULL.patch 0008-tirpc-with-pkgconfig.patch Patches modified: 0002-Patch-taken-from-Gentoo.patch 0003-Switch-legacy-index-in-favour-of-strchr.patch 0006-Let-the-configure-script-find-getrpcbynumber-in-libt.patch Patch addedd: 0004-statd-Fix-test-for-foreground-mode.patch Also, change source of the package to git repository (and remove the hash, sourceforce is clearly not a platform which can be trusted nowadays) Rework the startup script to accomodate new rpc.statd The startup scripts now uses rcp.statd -F for a startup in foreground, also we avoid starting it twice, it makes rcp.statd crash the whole script. [Thomas: add patch to fix rpc.statd foreground/daemon mode backported from upstream, and fix the S60nfs init script to not use the -F option of rpc.statd.] Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
61 lines
1.8 KiB
Diff
61 lines
1.8 KiB
Diff
From 5796ca01e33596d4102dd714349c908fecc331c0 Mon Sep 17 00:00:00 2001
|
|
From: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
|
Date: Sat, 10 Nov 2012 18:56:12 +0100
|
|
Subject: [PATCH] Patch taken from Gentoo
|
|
|
|
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
|
---
|
|
tools/locktest/Makefile.am | 7 +++----
|
|
tools/rpcgen/Makefile.am | 8 +++-----
|
|
2 files changed, 6 insertions(+), 9 deletions(-)
|
|
|
|
diff --git a/tools/locktest/Makefile.am b/tools/locktest/Makefile.am
|
|
index 3156815..efe6fcd 100644
|
|
--- a/tools/locktest/Makefile.am
|
|
+++ b/tools/locktest/Makefile.am
|
|
@@ -1,12 +1,11 @@
|
|
## Process this file with automake to produce Makefile.in
|
|
|
|
CC=$(CC_FOR_BUILD)
|
|
-LIBTOOL = @LIBTOOL@ --tag=CC
|
|
+CFLAGS=$(CFLAGS_FOR_BUILD)
|
|
+CPPFLAGS=$(CPPFLAGS_FOR_BUILD)
|
|
+LDFLAGS=$(LDFLAGS_FOR_BUILD)
|
|
|
|
noinst_PROGRAMS = testlk
|
|
testlk_SOURCES = testlk.c
|
|
-testlk_CFLAGS=$(CFLAGS_FOR_BUILD)
|
|
-testlk_CPPFLAGS=$(CPPFLAGS_FOR_BUILD)
|
|
-testlk_LDFLAGS=$(LDFLAGS_FOR_BUILD)
|
|
|
|
MAINTAINERCLEANFILES = Makefile.in
|
|
diff --git a/tools/rpcgen/Makefile.am b/tools/rpcgen/Makefile.am
|
|
index 8a9ec89..5a5b4d3 100644
|
|
--- a/tools/rpcgen/Makefile.am
|
|
+++ b/tools/rpcgen/Makefile.am
|
|
@@ -1,7 +1,9 @@
|
|
## Process this file with automake to produce Makefile.in
|
|
|
|
CC=$(CC_FOR_BUILD)
|
|
-LIBTOOL = @LIBTOOL@ --tag=CC
|
|
+CFLAGS=$(CFLAGS_FOR_BUILD)
|
|
+CPPFLAGS=$(CPPFLAGS_FOR_BUILD)
|
|
+LDFLAGS=$(LDFLAGS_FOR_BUILD)
|
|
|
|
noinst_PROGRAMS = rpcgen
|
|
rpcgen_SOURCES = rpc_clntout.c rpc_cout.c rpc_hout.c rpc_main.c \
|
|
@@ -9,10 +11,6 @@ rpcgen_SOURCES = rpc_clntout.c rpc_cout.c rpc_hout.c rpc_main.c \
|
|
rpc_util.c rpc_sample.c rpc_output.h rpc_parse.h \
|
|
rpc_scan.h rpc_util.h
|
|
|
|
-rpcgen_CFLAGS=$(CFLAGS_FOR_BUILD)
|
|
-rpcgen_CPPLAGS=$(CPPFLAGS_FOR_BUILD)
|
|
-rpcgen_LDFLAGS=$(LDFLAGS_FOR_BUILD)
|
|
-rpcgen_LDADD=$(LIBTIRPC)
|
|
|
|
MAINTAINERCLEANFILES = Makefile.in
|
|
|
|
--
|
|
2.1.0
|
|
|