5035b7819c
Since libatomic_ops does not implement real atomic operations for ARMv4 and ARMv5, libunwind must define AO_REQUIRE_CAS do indicate it requires compare-and-swap operations, even if not available as real atomic operations for the current architecture. In this case, libatomic_ops will rely on emulated atomic operations, which also require linking against libatomic_ops, which was until now not done by libunwind. This fixes the mysterious ltrace build issue: http://autobuild.buildroot.org/results/e1b/e1b330abfa2d80f3f30bc3359428ea429c690eb8/ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
33 lines
1018 B
Diff
33 lines
1018 B
Diff
Disable building of tests
|
|
|
|
libunwind tests do not build with uClibc, so we disable them.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
|
|
Index: b/Makefile.am
|
|
===================================================================
|
|
--- a/Makefile.am
|
|
+++ b/Makefile.am
|
|
@@ -36,7 +36,7 @@
|
|
|
|
nodist_include_HEADERS = include/libunwind-common.h
|
|
|
|
-SUBDIRS = src tests doc
|
|
+SUBDIRS = src doc
|
|
|
|
noinst_HEADERS = include/dwarf.h include/dwarf_i.h include/dwarf-eh.h \
|
|
include/compiler.h include/libunwind_i.h include/mempool.h \
|
|
Index: b/Makefile.in
|
|
===================================================================
|
|
--- a/Makefile.in
|
|
+++ b/Makefile.in
|
|
@@ -313,7 +313,7 @@
|
|
$(am__append_7) $(am__append_8) $(am__append_9) \
|
|
$(am__append_10)
|
|
nodist_include_HEADERS = include/libunwind-common.h
|
|
-SUBDIRS = src tests doc
|
|
+SUBDIRS = src doc
|
|
noinst_HEADERS = include/dwarf.h include/dwarf_i.h include/dwarf-eh.h \
|
|
include/compiler.h include/libunwind_i.h include/mempool.h \
|
|
include/remote.h \
|