9bb1034455
PostGIS is a spatial database extender for PostgreSQL object-relational database. It adds support for geographic objects allowing location queries to be run in SQL. On microblazeel with the bootlin toolchain, the build fails with an ICE: during RTL pass: reload .../bootlin-microblazeel-uclibc/build/libgeos-3.9.0/src/geom/util/Densifier.cpp: In static member function ‘static std::unique_ptr<std::vector<geos::geom::Coordinate> > geos::geom::util::Densifier::densifyPoints(geos::geom::Coordinate::Vect, double, const geos::geom::PrecisionModel*)’: .../bootlin-microblazeel-uclibc/build/libgeos-3.9.0/src/geom/util/Densifier.cpp:128:1: internal compiler error: in gen_reg_rtx, at emit-rtl.c:1155 128 | } | ^ Since it's unlikely that postgis will ever be used on a microblaze, simply disable it. https://postgis.net/ Signed-off-by: Maxim Kochetkov <fido_max@inbox.ru> Signed-off-by: Peter Seiderer <ps.report@gmx.net> Reviewed-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> [Arnout: - Move postgresql dependency to package/Config.in, to satisfy alphabetical ordering in the menu while keeping it below postgresql. - Add dependency on !microblaze. - Add comment for dependencies. - Add positive version of --with-raster and --with-protobuf to _CONF_OPTS. - Expand BSD to BSD-2-Clause. ]
32 lines
948 B
Diff
32 lines
948 B
Diff
From 845c18c1288b7a96592901baadb198f96dd71c46 Mon Sep 17 00:00:00 2001
|
|
From: fidomax <adobegitler@gmail.com>
|
|
Date: Tue, 26 Jan 2021 09:49:19 +0300
|
|
Subject: [PATCH] Disable forced static linking of liblwgeom
|
|
|
|
In case of shared libs build fails:
|
|
ld: cannot find -lgeos_c
|
|
ld: attempted static link of dynamic object `/usr/lib/libproj.so'
|
|
|
|
Signed-off-by: Maxim Kochetkov <fido_max@inbox.ru>
|
|
Fetch from: https://github.com/postgis/postgis/commit/98070faad220e12fcaed9a583a70a37c510b7c6b.patch
|
|
---
|
|
loader/Makefile.in | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/loader/Makefile.in b/loader/Makefile.in
|
|
index 9aebfe07f..9a0c90d3a 100644
|
|
--- a/loader/Makefile.in
|
|
+++ b/loader/Makefile.in
|
|
@@ -44,7 +44,7 @@ ICONV_CFLAGS=@ICONV_CFLAGS@
|
|
|
|
# liblwgeom
|
|
LIBLWGEOM=../liblwgeom/liblwgeom.la
|
|
-LDFLAGS += -static $(LIBLWGEOM)
|
|
+LDFLAGS += $(LIBLWGEOM)
|
|
|
|
# GTK includes and libraries
|
|
GTK_CFLAGS = @GTK_CFLAGS@ @IGE_MAC_CFLAGS@
|
|
--
|
|
2.30.0
|
|
|