a7e49eb2af
quite work yet for me, but this clearly is a huge project and not having it quite work on the first pass is hardly unexpected. We definately want this stuff in buildroot.
25 lines
818 B
Diff
25 lines
818 B
Diff
--- xf86-video-sunffb-1.1.0/configure.ac.orig 2007-06-10 21:01:18.000000000 +0200
|
|
+++ xf86-video-sunffb-1.1.0/configure.ac 2007-06-10 21:01:34.000000000 +0200
|
|
@@ -72,13 +72,20 @@
|
|
# Checks for header files.
|
|
AC_HEADER_STDC
|
|
|
|
-if test "$DRI" != no; then
|
|
+if test "x$DRI" != xno; then
|
|
+ if test "$cross_compiling" = "no" ; then
|
|
AC_CHECK_FILE([${sdkdir}/dri.h],
|
|
[have_dri_h="yes"], [have_dri_h="no"])
|
|
AC_CHECK_FILE([${sdkdir}/sarea.h],
|
|
[have_sarea_h="yes"], [have_sarea_h="no"])
|
|
AC_CHECK_FILE([${sdkdir}/dristruct.h],
|
|
[have_dristruct_h="yes"], [have_dristruct_h="no"])
|
|
+ AC_CHECK_HEADER
|
|
+ else
|
|
+ have_dri_h="yes"
|
|
+ have_sarea_h="yes"
|
|
+ have_dristruct_h="yes"
|
|
+ fi
|
|
fi
|
|
|
|
AC_MSG_CHECKING([whether to include DRI support])
|