kumquat-buildroot/package/mesa3d/0002-configure.ac-invert-order-for-wayland-scanner-check.patch
Bernd Kuhls 8b2c8690d1 package/{mesa3d, mesa3d-headers}: bump version to 18.0.1
Removed patch 0002, upstream committed a different fix:
https://cgit.freedesktop.org/mesa/mesa/commit/?h=18.1&id=cbee1bfb34274668a05995b9d4c78ddec9e5ea4c
https://cgit.freedesktop.org/mesa/mesa/commit/?h=18.1&id=5a75019ad0270a974788a9b8648ba98ff4203768

Renumbered patch 0003 -> 0002.

Tested using test-pkg (removed skipped toolchains from log):

                armv5-ctng-linux-gnueabi [ 1/46]: OK
              armv7-ctng-linux-gnueabihf [ 2/46]: OK
                        br-aarch64-glibc [ 3/46]: OK
                           br-arcle-hs38 [ 4/46]: OK
                  br-arm-cortex-a9-glibc [ 6/46]: OK
                   br-arm-cortex-a9-musl [ 7/46]: OK
                             br-arm-full [ 9/46]: OK
                   br-i386-pentium4-full [12/46]: OK
                br-i386-pentium-mmx-musl [13/46]: OK

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
2018-04-21 14:50:26 +02:00

45 lines
1.6 KiB
Diff

From 11a759c33160db6e887e7640071ba84482e6164f Mon Sep 17 00:00:00 2001
From: Gustavo Zacarias <gustavo@zacarias.com.ar>
Date: Thu, 17 Nov 2016 15:36:54 -0300
Subject: [PATCH] configure.ac: invert order for wayland-scanner check
When cross-compiling the .pc file might point to the wrong
wayland-scanner binary (target rather than host) resulting in a
non-executable and wrong scanner.
Try searching the PATH first, and if that fails fall back into
pkg-config.
[Vincent: tweak patch for 17.1.1 version]
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
[Romain: rebase on 17.3.1]
Signed-off-by: Romain Naour <romain.naour@gmail.com>
---
configure.ac | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/configure.ac b/configure.ac
index ee03d6f582..786b7214b9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1695,11 +1695,11 @@ if test "x$with_platforms" = xauto; then
with_platforms=$with_egl_platforms
fi
-PKG_CHECK_MODULES([WAYLAND_SCANNER], [wayland-scanner],
- WAYLAND_SCANNER=`$PKG_CONFIG --variable=wayland_scanner wayland-scanner`,
- WAYLAND_SCANNER='')
+AC_PATH_PROG([WAYLAND_SCANNER], [wayland-scanner])
if test "x$WAYLAND_SCANNER" = x; then
- AC_PATH_PROG([WAYLAND_SCANNER], [wayland-scanner], [:])
+ PKG_CHECK_MODULES([WAYLAND_SCANNER], [wayland-scanner],
+ WAYLAND_SCANNER=`$PKG_CONFIG --variable=wayland_scanner wayland-scanner`,
+ WAYLAND_SCANNER='')
fi
PKG_CHECK_EXISTS([wayland-protocols >= $WAYLAND_PROTOCOLS_REQUIRED], [have_wayland_protocols=yes], [have_wayland_protocols=no])
--
2.14.3