fffbd2c9f7
i2pd (I2P Daemon) is a full-featured C++ implementation of I2P client. I2P (Invisible Internet Protocol) is a universal anonymous network layer. All communications over I2P are anonymous and end-to-end encrypted, participants don't reveal their real IP addresses. http://i2pd.website Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> [Thomas: - Add third patch to not install the license file in /usr/LICENSE and the source code in /usr/src instead of using a post-install-target hook to remove /usr/LICENSE and /usr/src. Indeed, we're not sure if /usr/src contains only stuff installed by this package. - Clarify the comment that explains why -DTHREADS_PTHREAD_ARG=OFF is passed, especially because it's only needed for older versions of CMake, and causes a warning with newer versions of CMake. - Propagate architecture dependencies to the Config.in comment about the exception_ptr requirement.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
29 lines
932 B
Diff
29 lines
932 B
Diff
From 6d15be9a32989b0d00312a5b2589e36ba0ea7836 Mon Sep 17 00:00:00 2001
|
|
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
Date: Sun, 4 Mar 2018 18:29:13 +0100
|
|
Subject: [PATCH] Fix cmake error when -DBUILD_SHARED_LIBS=ON
|
|
|
|
Fixes "CMake Error: TARGETS given no LIBRARY DESTINATION for shared
|
|
library target" by adding LIBRARY parameter to INSTALL call
|
|
|
|
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
---
|
|
build/CMakeLists.txt | 1 +
|
|
1 file changed, 1 insertion(+)
|
|
|
|
diff --git a/build/CMakeLists.txt b/build/CMakeLists.txt
|
|
index 4f875b33..a1c8957b 100644
|
|
--- a/build/CMakeLists.txt
|
|
+++ b/build/CMakeLists.txt
|
|
@@ -97,6 +97,7 @@ set_target_properties(libi2pd PROPERTIES PREFIX "")
|
|
install(TARGETS libi2pd
|
|
EXPORT libi2pd
|
|
ARCHIVE DESTINATION lib
|
|
+ LIBRARY DESTINATION lib
|
|
COMPONENT Libraries)
|
|
# TODO Make libi2pd available to 3rd party projects via CMake as imported target
|
|
# FIXME This pulls stdafx
|
|
--
|
|
2.14.1
|
|
|