7227d005d2
Signed-off-by: Peter Seiderer <ps.report@gmx.net> [yann.morin.1998@free.fr: - only depend on libx11-xlib or libexpoxy if actually enabled - simplify qt5 dependency - fix check-package ] Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
38 lines
1.4 KiB
Diff
38 lines
1.4 KiB
Diff
From 6bd733b52f0b4039407c676cd3126a9e2f79456b Mon Sep 17 00:00:00 2001
|
||
From: Peter Seiderer <ps.report@gmx.net>
|
||
Date: Fri, 5 Feb 2021 18:24:08 +0100
|
||
Subject: [PATCH] cmake: remove -Werror and -Wfatal-errors compiler command
|
||
line option
|
||
MIME-Version: 1.0
|
||
Content-Type: text/plain; charset=UTF-8
|
||
Content-Transfer-Encoding: 8bit
|
||
|
||
Fixes (with bootlin-riscv64-musl toolchain):
|
||
|
||
.../build/libcamera-apps-2d1009e3badcc8047361ff81149ad6cba3b911b5/core/libcamera_app.cpp:30:22: error: overflow in conversion from ‘long unsigned int’ to ‘int’ changes value from ‘2154321408’ to ‘-2140645888’ [-Werror=overflow]
|
||
30 | int ret = ioctl(fd, VIDIOC_QUERYCAP, &caps);
|
||
| ^~~~~~~~~~~~~~~
|
||
cc1plus: all warnings being treated as errors
|
||
|
||
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
|
||
---
|
||
CMakeLists.txt | 2 +-
|
||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||
|
||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||
index 748c6dd..1ca1e39 100644
|
||
--- a/CMakeLists.txt
|
||
+++ b/CMakeLists.txt
|
||
@@ -11,7 +11,7 @@ endif()
|
||
|
||
set (CMAKE_EXPORT_COMPILE_COMMANDS ON)
|
||
set (CMAKE_CXX_STANDARD 17)
|
||
-add_compile_options(-Wall -Wextra -pedantic -Wno-unused-parameter -faligned-new -Werror -Wfatal-errors)
|
||
+add_compile_options(-Wall -Wextra -pedantic -Wno-unused-parameter -faligned-new)
|
||
add_definitions(-D_FILE_OFFSET_BITS=64)
|
||
|
||
if (CMAKE_COMPILER_IS_GNUCXX)
|
||
--
|
||
2.34.1
|
||
|