26c16e9d5b
patch 0005 has been sourced from upstream, and can be dropped when 7.4.3 is released. The mbstrings module used to use a bundled oniguruma library, but now uses an external one, hence the new dependency on this package for the mbstrings module. The hash of the license file has changed due to this change in the copyright year: -Copyright (c) 1999 - 2018 The PHP Group. All rights reserved. +Copyright (c) 1999 - 2019 The PHP Group. All rights reserved. Signed-off-by: Pascal de Bruijn <p.debruijn@unilogic.nl> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
42 lines
1.4 KiB
Diff
42 lines
1.4 KiB
Diff
From 5ba6355e489f647c88ca48afbc75965468193181 Mon Sep 17 00:00:00 2001
|
|
From: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
|
Date: Tue, 9 Aug 2016 11:51:53 +0200
|
|
Subject: [PATCH] configure: disable the 'phar' tool
|
|
|
|
Disable the 'phar' command-line tool build/installation since it requires
|
|
php to run and pack up phar itself in phar format. This would require
|
|
a host-php instance and really probably nobody needs the phar tool
|
|
on the target.
|
|
|
|
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
|
[Gustavo: update for autoreconf/configure.in]
|
|
Signed-off-by: Adam Duskett <aduskett@gmail.com>
|
|
[Aduskett: update for 7.3.0]
|
|
---
|
|
configure.ac | 9 ++-------
|
|
1 file changed, 2 insertions(+), 7 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 0dfab302..6026fb66 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -1430,13 +1430,8 @@ CFLAGS="\$(CFLAGS_CLEAN) $standard_libtool_flag"
|
|
INLINE_CFLAGS="$INLINE_CFLAGS $standard_libtool_flag"
|
|
CXXFLAGS="$CXXFLAGS $standard_libtool_flag \$(PROF_FLAGS)"
|
|
|
|
-if test "$PHP_PHAR" != "no" && test "$PHP_CLI" != "no"; then
|
|
- pharcmd=pharcmd
|
|
- pharcmd_install=install-pharcmd
|
|
-else
|
|
- pharcmd=
|
|
- pharcmd_install=
|
|
-fi;
|
|
+pharcmd=
|
|
+pharcmd_install=
|
|
|
|
all_targets="$lcov_target \$(OVERALL_TARGET) \$(PHP_MODULES) \$(PHP_ZEND_EX) \$(PHP_BINARIES) $pharcmd"
|
|
install_targets="$install_sapi $install_modules $install_binaries install-build install-headers install-programs $install_pear $pharcmd_install"
|
|
--
|
|
2.14.3
|
|
|