a7e49eb2af
quite work yet for me, but this clearly is a huge project and not having it quite work on the first pass is hardly unexpected. We definately want this stuff in buildroot.
16 lines
613 B
Diff
16 lines
613 B
Diff
--- xdm-1.1.3/configure.ac.orig 2007-06-10 15:34:10.000000000 +0200
|
|
+++ xdm-1.1.3/configure.ac 2007-06-10 15:38:33.000000000 +0200
|
|
@@ -152,8 +152,12 @@
|
|
RANDOM_DEVICE="$withval", RANDOM_DEVICE="try")
|
|
|
|
if test x$RANDOM_DEVICE = xyes -o x$RANDOM_DEVICE = xtry ; then
|
|
+ if test "$cross_compiling" = "no" ; then
|
|
AC_CHECK_FILE([/dev/urandom], [RANDOM_DEVICE=/dev/urandom],
|
|
AC_CHECK_FILE([/dev/random], [RANDOM_DEVICE=/dev/random]))
|
|
+ else
|
|
+ RANDOM_DEVICE=/dev/urandom
|
|
+ fi
|
|
if test x$RANDOM_DEVICE = xyes ; then
|
|
AC_MSG_ERROR(["random device support requested, but no random device was found."])
|
|
else
|