31e5b10ea8
And renumber remaining patches. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
28 lines
1.1 KiB
Diff
28 lines
1.1 KiB
Diff
From 16b2b0e21e10727065042a1baabd1a887757c65c Mon Sep 17 00:00:00 2001
|
|
From: Adam Duskett <Adamduskett@outlook.com>
|
|
Date: Mon, 9 Oct 2017 16:29:36 -0400
|
|
Subject: [PATCH] Makefile: revert libsepol: use ln --relative to create .so symlinks
|
|
|
|
This reverts 71393a181d63c9baae5fe8dcaeb9411d1f253998
|
|
|
|
ln --relative is too recent to be available in all distributions,
|
|
especially enterprise-grade distros that can stick around as long as
|
|
they are maintained (up to 10 years in some cases?).
|
|
|
|
For the sake of Buildroot, revert the upstream patch.
|
|
|
|
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
|
|
|
|
diff -durNw libsepol-2.7.orig/src/Makefile libsepol-2.7/src/Makefile
|
|
--- libsepol-2.7.orig/src/Makefile 2018-01-15 21:37:12.821831315 +0100
|
|
+++ libsepol-2.7/src/Makefile 2018-01-15 21:38:03.838497434 +0100
|
|
@@ -92,7 +92,7 @@
|
|
endif
|
|
test -d $(LIBINSTALL)/pkgconfig || install -m 755 -d $(LIBINSTALL)/pkgconfig
|
|
install -m 644 $(LIBPC) $(LIBINSTALL)/pkgconfig
|
|
- $(LN) -sf --relative $(LIBINSTALL)/$(LIBSO) $(LIBINSTALL)/$(TARGET)
|
|
+ cd $(LIBINSTALL) && ln -sf $(LIBSO) $(TARGET)
|
|
|
|
relabel:
|
|
/sbin/restorecon $(LIBINSTALL)/$(LIBSO)
|