40cc40ce24
Fix the following build failure with convolution raised since bump of
automake to version 1.16.5 in commit
446d9f5102
and
https://git.savannah.gnu.org/cgit/automake.git/commit/?id=f4a3a70f69e1dbccb6578f39ef47835098a04624:
configure.ac:305: error: AM_INIT_AUTOMAKE expanded multiple times
/home/giuliobenetti/autobuild/run/instance-1/output-1/host/share/aclocal-1.16/init.m4:29: AM_INIT_AUTOMAKE is expanded from...
configure.ac:6: the top level
/home/giuliobenetti/autobuild/run/instance-1/output-1/host/share/aclocal-1.16/init.m4:29: AM_INIT_AUTOMAKE is expanded from...
configure.ac:305: the top level
Fixes:
- http://autobuild.buildroot.org/results/464148bdccb705d8992dc860262bfdeb01b7e2a1
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
49 lines
1.9 KiB
Diff
49 lines
1.9 KiB
Diff
From ad22edb303a470b6f9eda9fd9d3f588bb2eff8cb Mon Sep 17 00:00:00 2001
|
|
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
Date: Fri, 15 Oct 2021 08:02:23 +0200
|
|
Subject: [PATCH] configure.ac: fix build with automake 1.16.5
|
|
|
|
Fix the following build failure with convolution raised since automake
|
|
1.16.5 and
|
|
https://git.savannah.gnu.org/cgit/automake.git/commit/?id=f4a3a70f69e1dbccb6578f39ef47835098a04624:
|
|
|
|
configure.ac:305: error: AM_INIT_AUTOMAKE expanded multiple times
|
|
/home/giuliobenetti/autobuild/run/instance-1/output-1/host/share/aclocal-1.16/init.m4:29: AM_INIT_AUTOMAKE is expanded from...
|
|
configure.ac:6: the top level
|
|
/home/giuliobenetti/autobuild/run/instance-1/output-1/host/share/aclocal-1.16/init.m4:29: AM_INIT_AUTOMAKE is expanded from...
|
|
configure.ac:305: the top level
|
|
|
|
Fixes:
|
|
- http://autobuild.buildroot.org/results/464148bdccb705d8992dc860262bfdeb01b7e2a1
|
|
|
|
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
[Upstream status: https://github.com/mikebrady/shairport-sync/pull/1314]
|
|
---
|
|
configure.ac | 3 +--
|
|
1 file changed, 1 insertion(+), 2 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index f77087c5..aa533a2d 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -3,7 +3,7 @@
|
|
|
|
AC_PREREQ([2.50])
|
|
AC_INIT([shairport-sync], [3.3.8], [4265913+mikebrady@users.noreply.github.com])
|
|
-AM_INIT_AUTOMAKE
|
|
+AM_INIT_AUTOMAKE([subdir-objects])
|
|
AC_CONFIG_SRCDIR([shairport.c])
|
|
AC_CONFIG_HEADERS([config.h])
|
|
AC_PROG_RANLIB
|
|
@@ -302,7 +302,6 @@ AM_CONDITIONAL([USE_PA], [test "x$with_pa" = "xyes"])
|
|
# Look for Convolution flag
|
|
AC_ARG_WITH(convolution, [AS_HELP_STRING([--with-convolution],[choose audio DSP convolution support])])
|
|
if test "x$with_convolution" = "xyes" ; then
|
|
- AM_INIT_AUTOMAKE([subdir-objects])
|
|
AC_DEFINE([CONFIG_CONVOLUTION], 1, [Include audio DSP convolution support.])
|
|
AC_CHECK_LIB([sndfile], [sf_open], , AC_MSG_ERROR(Convolution support requires the sndfile library -- libsndfile1-dev suggested!))
|
|
fi
|
|
--
|
|
2.33.0
|
|
|