309b466a1d
This patch bumps to mono 5.0.1.1 and updates the unit tests patch accordingly. The latest version of mono carries a bit of changes in the monolite package: the version string changes and from now on, monolite should be installed in a subdirectory with the exact version string as a name. Therefore, mono and monolite are bumped in a single commit. Patch 0004, although applied in upstream master, is not yet in this (stable) release. Signed-off-by: Angelo Compagnucci <angelo.compagnucci@gmail.com> [Arnout: squashed the patches, removed /usr part from HOST_DIR] Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
30 lines
1.1 KiB
Diff
30 lines
1.1 KiB
Diff
From 26e31fc54af591bdd88d6a4a79b7fa91c57f4b0c Mon Sep 17 00:00:00 2001
|
|
From: Angelo Compagnucci <angelo.compagnucci@gmail.com>
|
|
Date: Thu, 10 Aug 2017 23:30:05 +0200
|
|
Subject: [PATCH] Remove unit-tests from mono compilation
|
|
|
|
This patch fixes compiling errors with unit-tests under linux.
|
|
|
|
Signed-off-by: Angelo Compagnucci <angelo.compagnucci@gmail.com>
|
|
---
|
|
mono/Makefile.am | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/mono/Makefile.am b/mono/Makefile.am
|
|
index 8c9c2cb..7af36ec 100644
|
|
--- a/mono/Makefile.am
|
|
+++ b/mono/Makefile.am
|
|
@@ -34,7 +34,7 @@ monotouch-do-clean:
|
|
(cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) $$target); \
|
|
done;
|
|
else
|
|
-SUBDIRS = $(btls_dirs) arch utils cil metadata $(sgen_dirs) mini dis tests unit-tests benchmark profiler
|
|
+SUBDIRS = $(btls_dirs) arch utils cil metadata $(sgen_dirs) mini dis tests benchmark profiler
|
|
endif
|
|
endif
|
|
-DIST_SUBDIRS = btls arch utils cil metadata $(sgen_dirs) mini dis tests unit-tests benchmark profiler
|
|
+DIST_SUBDIRS = btls arch utils cil metadata $(sgen_dirs) mini dis tests benchmark profiler
|
|
--
|
|
2.7.4
|
|
|