kumquat-buildroot/package/php/0005-allow-opcache-cross-compiling.patch
Bernd Kuhls e50460f9f1 package/php: bump version to 8.3.4
Removed patch 0006 which is included in this release.
Rebased patch 0005.

Changelog: https://www.php.net/ChangeLog-8.php#PHP_8_3
Release notes: https://www.php.net/releases/8_3_4.php
Release notes: https://www.php.net/releases/8_3_3.php
Release notes: https://www.php.net/releases/8_3_2.php
Release notes: https://www.php.net/releases/8_3_1.php
Release notes: https://www.php.net/releases/8_3_0.php

Signed-off-by: Bernd Kuhls <bernd@kuhls.net>
Signed-off-by: Arnout Vandecappelle <arnout@mind.be>
2024-03-24 16:33:36 +01:00

40 lines
1.3 KiB
Diff

From 9bb316c41a69935ee2072626467241889594bed4 Mon Sep 17 00:00:00 2001
From: Adam Duskett <aduskett@gmail.com>
Date: Mon, 28 Jun 2021 11:12:36 -0700
Subject: [PATCH] allow opcache cross-compiling
Remove the check at the end of ext/opcache/config.m4 that prevents opcache from
being enabled in a cross-compiled environment. We pass the following as a
CFLAGS when opcache is enabled:
-DHAVE_SHM_IPC
-DHAVE_SHM_MMAP_ANON
-DHAVE_SHM_MMAP_ZERO
-DHAVE_SHM_MMAP_POSIX
-DHAVE_SHM_MMAP_FILE
Signed-off-by: Adam Duskett <aduskett@gmail.com>
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
[Bernd: rebased for 8.1.7 & 8.3.3]
---
ext/opcache/config.m4 | 4 ----
1 file changed, 4 deletions(-)
diff --git a/ext/opcache/config.m4 b/ext/opcache/config.m4
index 5492fd92..10c150ff 100644
--- a/ext/opcache/config.m4
+++ b/ext/opcache/config.m4
@@ -315,10 +315,6 @@ int main() {
PHP_ADD_EXTENSION_DEP(opcache, pcre)
- if test "$have_shm_ipc" != "yes" && test "$have_shm_mmap_posix" != "yes" && test "$have_shm_mmap_anon" != "yes"; then
- AC_MSG_ERROR([No supported shared memory caching support was found when configuring opcache. Check config.log for any errors or missing dependencies.])
- fi
-
if test "$PHP_OPCACHE_JIT" = "yes"; then
PHP_ADD_BUILD_DIR([$ext_builddir/jit], 1)
PHP_ADD_MAKEFILE_FRAGMENT($ext_srcdir/jit/Makefile.frag)
--
2.31.1