b259dac22a
Our dmalloc packaging is very old and carries historical baggage and idiosyncracies that we have long stopped doing in the rest ofthe code base. Drop our post-patch hooks that seds the configure and Makefile.in files, and add patches (that could be upstreamed one day). We provide the results in the environment, like would be done with actual autoconf cache variables (ac_cv_*). Note: those are the result of cleaning up for further patches that did not manifest because it was too complex to add proper SSP support to dmalloc (instead, we're going to forcibly disable it in the following commit). Note-2: those patches have not been submitted upstream, as it's mostly dead: even though there's been some commit activities recently-ish, there has been no review or comments or the many PR pending for many years now. Note-3: we patch both configure and configure.ac, rather than autoreconf, for two reasons: 1. the both are in the upstream git tree, so submitting these patches would require patching both, and 2. dmalloc does not autoreconf nicely out of the box, and it was deemed too much hassle to fix that in addition. Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr> Cc: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
51 lines
1.1 KiB
Diff
51 lines
1.1 KiB
Diff
From c958fd5cd7d5ff03c0a023608b53b74997c514b3 Mon Sep 17 00:00:00 2001
|
|
From: "Yann E. MORIN" <yann.morin.1998@free.fr>
|
|
Date: Wed, 8 Feb 2023 13:43:55 +0100
|
|
Subject: [PATCH] Makefile: use the configure-detected or user-supplied ar
|
|
program
|
|
|
|
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
|
|
---
|
|
Makefile.in | 8 ++++----
|
|
1 file changed, 4 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/Makefile.in b/Makefile.in
|
|
index 86d3cca..089ac99 100644
|
|
--- a/Makefile.in
|
|
+++ b/Makefile.in
|
|
@@ -303,11 +303,11 @@ $(LIB_SL) : $(LIBRARY)
|
|
mv $@.t $@
|
|
|
|
$(LIBRARY) : $(OBJS) $(NORMAL_OBJS)
|
|
- ar cr $@ $?
|
|
+ $(AR) cr $@ $?
|
|
@RANLIB@ $@
|
|
|
|
$(LIB_TH) : $(OBJS) $(THREAD_OBJS)
|
|
- ar cr $@ $?
|
|
+ $(AR) cr $@ $?
|
|
@RANLIB@ $@
|
|
|
|
$(LIB_TH_SL) : $(LIB_TH)
|
|
@@ -316,7 +316,7 @@ $(LIB_TH_SL) : $(LIB_TH)
|
|
mv $@.t $@
|
|
|
|
$(LIB_CXX) : $(OBJS) $(NORMAL_OBJS) $(CXX_OBJS)
|
|
- ar cr $@ $?
|
|
+ $(AR) cr $@ $?
|
|
@RANLIB@ $@
|
|
|
|
$(LIB_CXX_SL) : $(LIB_CXX)
|
|
@@ -325,7 +325,7 @@ $(LIB_CXX_SL) : $(LIB_CXX)
|
|
mv $@.t $@
|
|
|
|
$(LIB_TH_CXX) : $(OBJS) $(THREAD_OBJS) $(CXX_OBJS)
|
|
- ar cr $@ $?
|
|
+ $(AR) cr $@ $?
|
|
@RANLIB@ $@
|
|
|
|
$(LIB_TH_CXX_SL) : $(LIB_TH_CXX)
|
|
--
|
|
2.25.1
|
|
|