kumquat-buildroot/package/liboil/liboil-vfp.patch
Ulf Samuelsson 6da70de503 The liboil Makefile will use "-mcpu=vfp" when building for ARM.
The VFP is only available for a few ARM CPUs at the moment,
so this breaks the liboil build.

A patch is available upstream which only enables "-mfpu=vfp"
if "--enable-vfp" is given to "configure".
Autotools needs to be run for liboil for this to take effect.

A new configuration BR2_VFP_FLOAT is added to allow enabling vfp.
If this is "yes", then "-mfpu=vfp" is added to CFLAGS.
2009-01-18 10:51:53 +00:00

17 lines
596 B
Diff

diff --git a/configure.ac b/configure.ac
index 06a0ac9..b8d1640 100644
--- a/configure.ac
+++ b/configure.ac
@@ -158,7 +158,10 @@ if test x$HAVE_GCC_ASM = xyes -a x$HAVE_POWERPC = xyes ; then
true)
fi
-if test x$HAVE_GCC_ASM = xyes -a x$HAVE_ARM = xyes ; then
+AC_ARG_ENABLE(vfp,
+ AC_HELP_STRING([--enable-vfp],[compile with Vector Floating-point unit support]),
+ enable_vfp=$enableval,enable_vfp=yes)
+if test "x$enable-vfp" = xyes -a x$HAVE_GCC_ASM = xyes -a x$HAVE_ARM = xyes; then
AS_COMPILER_FLAG(["-Wa,-mfpu=vfp"],
[LIBOIL_CFLAGS="$LIBOIL_CFLAGS -mfpu=vfp"],
true)