d4e56ff4dc
Based on googlecode r558 by John Voltz.
22 lines
735 B
Diff
22 lines
735 B
Diff
--- xf86-video-sis-0.9.3/configure.ac.orig 2007-06-10 21:00:29.000000000 +0200
|
|
+++ xf86-video-sis-0.9.3/configure.ac 2007-06-10 21:00:45.000000000 +0200
|
|
@@ -71,12 +71,18 @@
|
|
AC_HEADER_STDC
|
|
|
|
if test "$DRI" != no; then
|
|
+ if test "$cross_compiling" = "no" ; then
|
|
AC_CHECK_FILE([${sdkdir}/dri.h],
|
|
[have_dri_h="yes"], [have_dri_h="no"])
|
|
AC_CHECK_FILE([${sdkdir}/sarea.h],
|
|
[have_sarea_h="yes"], [have_sarea_h="no"])
|
|
AC_CHECK_FILE([${sdkdir}/dristruct.h],
|
|
[have_dristruct_h="yes"], [have_dristruct_h="no"])
|
|
+ else
|
|
+ have_dri_h="yes"
|
|
+ have_sarea_h="yes"
|
|
+ have_dristruct_h="yes"
|
|
+ fi
|
|
fi
|
|
|
|
AC_MSG_CHECKING([whether to include DRI support])
|