5bf4a4fe92
Changed download location, added popt dependency and updated the Makefile.in patch. Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
36 lines
1.2 KiB
Diff
36 lines
1.2 KiB
Diff
Fix Makefile.in
|
|
|
|
* Use $(CC) instead of $(CPP) to generate .depend file because
|
|
'$(CPP) -M' call does not support multiple input files.
|
|
This avoid the following error:
|
|
|
|
make[1]: Entering directory `/opt/br/output/build/newt-0.51.0'
|
|
/opt/br/output/host/usr/bin/arm-none-linux-gnueabi-cpp -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -M newt.c button.c form.c checkbox.c entry.c label.c listbox.c scrollbar.c textbox.c scale.c grid.c windows.c buttonbar.c checkboxtree.c > .depend
|
|
arm-none-linux-gnueabi-cpp: too many input files
|
|
make[1]: *** [depend] Error 1
|
|
make[1]: Leaving directory
|
|
`/opt/br/output/build/newt-0.51.0'
|
|
make: ***
|
|
[/opt/br/output/build/newt-0.51.0/.stamp_built] Error 2
|
|
|
|
Signed-off-by: Samuel Martin <s.martin49@gmail.com>
|
|
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
|
|
|
|
---
|
|
Makefile.in | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
Index: b/Makefile.in
|
|
===================================================================
|
|
--- a/Makefile.in
|
|
+++ b/Makefile.in
|
|
@@ -121,7 +121,7 @@
|
|
$(SHAREDDIR)/*.o *.$(SOEXT)*
|
|
|
|
depend:
|
|
- $(CPP) $(CFLAGS) $(CPPFLAGS) -M $(SOURCES) > .depend
|
|
+ $(CC) $(CFLAGS) $(CPPFLAGS) -M $(SOURCES) > .depend
|
|
|
|
$(SHAREDDIR):
|
|
mkdir -p $(SHAREDDIR)
|