f6d00867f9
The shared-mime-info package contains the core database of common types and the update-mime-database command used to extend it. The only thing that is actually needed in the target is the file mime.cache. In order to generate that file, shared-mime-info is installed into the staging-dir. The idea is that other packages might add more mime-info files and these should be collected in staging-dir. From there the mime.cache file is created using tools installed in host-dir and copied to target. From Sven Neumann <s.neumann@raumfeld.com> Modifications by Thomas Petazzoni : * Add a patch to the main Makefile.am so that the $(XMLLINT) variable is used instead of hardcoding xmllint * Apply the patch in the host build of shared-mime-info * In the target build, pass an XMLLINT environment variable so that the xmllint binary isn't searched in $(STAGING_DIR) but in $(HOST_DIR) Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
18 lines
653 B
Diff
18 lines
653 B
Diff
---
|
|
Makefile.am | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
Index: shared-mime-info-0.60/Makefile.am
|
|
===================================================================
|
|
--- shared-mime-info-0.60.orig/Makefile.am
|
|
+++ shared-mime-info-0.60/Makefile.am
|
|
@@ -72,7 +72,7 @@
|
|
|
|
check: freedesktop.org.xml
|
|
if test -n $(XMLLINT) ; then \
|
|
- xmllint --noout --valid $(top_srcdir)/freedesktop.org.xml; \
|
|
+ $(XMLLINT) --noout --valid $(top_srcdir)/freedesktop.org.xml; \
|
|
fi
|
|
if test -d CVS/ && test -x ../xdgmime/src/test-mime-data && test -x $(top_builddir)/test-tree-magic ; then \
|
|
mkdir -p $(top_builddir)/temp-mime-dir/mime/packages ; \
|