kumquat-buildroot/package/qt5/qt5base/5.6.2/0001-eglfs-rasp-pi-header-inclusion.patch
Naumann Andreas aa1c40ba37 qt5: add choice between version 5.6.2 and 5.8.0
For 5.8.0
- add hashes
- qt5 need C++11 compliant compiler since 5.7 ([1])
- use different licenses: since version 5.7 Qt removed the LGPL v2.1 option in favor
  of v3 with a different exception
- qt5base: renamed library to EglFSDeviceIntegration ([2])
- qt5base: remove ras-pi patch, commit c0cc5052097c723d0331a7619d686af9eb93d33c fix it ([3])
- qt5base: remove 0007-eglfs-fix-eglfs_mali-compile-for-odroid-mali.patch (upstream committed [3b])
- qt5base: remove obsolete config-option -large ([4])
- qt5base: gstreamer support fully moved to qt5multimedia, so gstreamer
  related options are no longer passed ([5])
- add patch for python-pyqt5 to fix the build with Qt 5.8
- add tweak in libv4l to fix the build with Qt 5.8, originally provided
  by Peter Seiderer
- add patch from Peter Seiderer fixing a build issue with freetype

For 5.6.2
- moved patches to subdir, and renumber patches

[1]  http://blog.qt.io/blog/2016/06/16/qt-5-7-released/
[2]  https://code.qt.io/cgit/qt/qtbase.git/commit/?id=ec4eb4db61094179bc6a9ec26ec68fb710177053
[3]  https://codereview.qt-project.org/#/c/167172/
[3b] https://code.qt.io/cgit/qt/qtbase.git/commit/?id=f1b4bd4790860e1ff5afcec111a359bc3a91cfda
[4]  https://code.qt.io/cgit/qt/qtbase.git/commit/?id=84d3a21c9efe7efb2cce6d3bd14af1f9580b1108
[5]  https://code.qt.io/cgit/qt/qtbase.git/commit/?id=7d4da559afb62a779b3d90a65fb679cb5433f203

Signed-off-by: Andreas Naumann <anaumann@ultratronik.de>
Signed-off-by: Julien Corjon <corjon.j@ecagroup.com>
Signed-off-by: Zoltan Gyarmati <mr.zoltan.gyarmati@gmail.com>
[Thomas:
 - tweak commit log about GStreamer related changes, suggested by Arnout
 - move the gcc 4.8 dependency from the main qt5 option to just the
   qt5.8 selection, so that qt5.6 can still be built if gcc < 4.8 is
   used. Noticed by Arnout.
 - rename the options of the version selection to not include the
   version number itself so that we don't have to keep legacy
   symbols. Noticed by Arnout.
 - introduce changes to qt5quickcontrols2.mk needed to handle qt5.6
   vs. qt5.8, borrowed from a later patch in the series.
 - add patch for python-pyqt5 to fix the build with Qt 5.8.
 - add fix to libv4l.mk from Peter Seiderer to fix the build with Qt
   5.8.
 - renumber patches for 5.6.2, suggested by Arnout.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2017-02-07 17:46:48 +01:00

46 lines
1.4 KiB
Diff

From 91c3b111e45dd476aba057836b1b618eacf90f3f Mon Sep 17 00:00:00 2001
From: Julien Corjon <corjon.j@ecagroup.com>
Date: Tue, 21 Jul 2015 09:58:14 +0200
Subject: [PATCH] eglfs - fix rasp-pi header inclusion
eglplateform.h include headers for low level instruction and fail on brcm
headers inclusion
For the brcm presence test we use egl pkg-config file
For the eglfs-plugin compilation we use the egl configuration
Upstream-Status: https://bugreports.qt.io/browse/QTBUG-47339
Signed-off-by: Julien Corjon <corjon.j@ecagroup.com>
---
config.tests/qpa/eglfs-brcm/eglfs-brcm.pro | 2 ++
src/plugins/platforms/eglfs/eglfs-plugin.pro | 1 +
2 files changed, 3 insertions(+)
diff --git a/config.tests/qpa/eglfs-brcm/eglfs-brcm.pro b/config.tests/qpa/eglfs-brcm/eglfs-brcm.pro
index ce16a3a..192a8ad 100644
--- a/config.tests/qpa/eglfs-brcm/eglfs-brcm.pro
+++ b/config.tests/qpa/eglfs-brcm/eglfs-brcm.pro
@@ -1,6 +1,8 @@
SOURCES = eglfs-brcm.cpp
CONFIG -= qt
+CONFIG += link_pkgconfig
+PKGCONFIG += egl
INCLUDEPATH += $$QMAKE_INCDIR_EGL
diff --git a/src/plugins/platforms/eglfs/eglfs-plugin.pro b/src/plugins/platforms/eglfs/eglfs-plugin.pro
index 0f493fd..8479496 100644
--- a/src/plugins/platforms/eglfs/eglfs-plugin.pro
+++ b/src/plugins/platforms/eglfs/eglfs-plugin.pro
@@ -6,6 +6,7 @@ PLUGIN_CLASS_NAME = QEglFSIntegrationPlugin
load(qt_plugin)
QT += platformsupport-private eglfs_device_lib-private
+CONFIG += egl
SOURCES += $$PWD/qeglfsmain.cpp
--
2.1.0