b22a190333
Fix build of version 3.0.0 with uclibc. While the patch is added in package/libapparmor, it in fact fixes a build issue that only occurs when building package/apparmor, but as both packages share the same source, they also share the same patches. Fixes: - http://autobuild.buildroot.org/results/aea20bd5539fad35385565ffeb7e6ac566507017 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
38 lines
1.4 KiB
Diff
38 lines
1.4 KiB
Diff
From 0dbcbee70097ecde66708064ec1dedfa64e581e8 Mon Sep 17 00:00:00 2001
|
|
From: Armin Kuster <akuster@mvista.com>
|
|
Date: Wed, 7 Oct 2020 20:50:38 -0700
|
|
Subject: [PATCH] parser/Makefile: dont force host cpp to detect reallocarray
|
|
|
|
In cross build environments, using the hosts cpp gives incorrect
|
|
detection of reallocarray. Change cpp to a variable.
|
|
|
|
fixes:
|
|
parser_misc.c: In function 'int capable_add_cap(const char*, int, unsigned int, capability_flags)':
|
|
| parser_misc.c:297:37: error: 'reallocarray' was not declared in this scope
|
|
| 297 | tmp = (struct capability_table *) reallocarray(cap_table, sizeof(struct capability_table), cap_table_size+1);
|
|
|
|
Signed-off-by: Armin Kuster <akuster808@gmail.com>
|
|
[Retrieved from:
|
|
https://gitlab.com/ffontaine/apparmor/-/commit/0dbcbee70097ecde66708064ec1dedfa64e581e8]
|
|
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
---
|
|
parser/Makefile | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/parser/Makefile b/parser/Makefile
|
|
index acef3d77a..8250ac451 100644
|
|
--- a/parser/Makefile
|
|
+++ b/parser/Makefile
|
|
@@ -54,7 +54,7 @@ endif
|
|
CPPFLAGS += -D_GNU_SOURCE
|
|
|
|
STDLIB_INCLUDE:="\#include <stdlib.h>"
|
|
-HAVE_REALLOCARRAY:=$(shell echo $(STDLIB_INCLUDE) | cpp ${CPPFLAGS} | grep -q reallocarray && echo true)
|
|
+HAVE_REALLOCARRAY:=$(shell echo $(STDLIB_INCLUDE) | ${CPP} ${CPPFLAGS} | grep -q reallocarray && echo true)
|
|
|
|
WARNINGS = -Wall
|
|
CXX_WARNINGS = ${WARNINGS} ${EXTRA_WARNINGS}
|
|
--
|
|
GitLab
|
|
|