5d76cf129f
As suggested by Arnout during review of previous iteration, add a patch to uboot-tools so it uses CFLAGS and not HOSTCFLAGS when building cross tools Fixes: - http://autobuild.buildroot.org/results/915b509e814bda16be54a24276b9c740c51e5770 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
29 lines
826 B
Diff
29 lines
826 B
Diff
From 9f2dce5887bb52e8c7f9ef40a6733d70af72ff1c Mon Sep 17 00:00:00 2001
|
|
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
Date: Tue, 30 Apr 2019 18:45:17 +0200
|
|
Subject: [PATCH] tools/Makefile: fix HOSTCFLAGS with CROSS_BUILD_TOOLS
|
|
|
|
When CROSS_BUILD_TOOLS is set, set HOSTCFLAGS to CFLAGS otherwise CC
|
|
will be used with HOSTCFLAGS which seems wrong
|
|
|
|
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
---
|
|
tools/Makefile | 1 +
|
|
1 file changed, 1 insertion(+)
|
|
|
|
diff --git a/tools/Makefile b/tools/Makefile
|
|
index 12a3027e23..eadeba417d 100644
|
|
--- a/tools/Makefile
|
|
+++ b/tools/Makefile
|
|
@@ -272,6 +272,7 @@ subdir- += env
|
|
|
|
ifneq ($(CROSS_BUILD_TOOLS),)
|
|
override HOSTCC = $(CC)
|
|
+override HOSTCFLAGS = $(CFLAGS)
|
|
|
|
quiet_cmd_crosstools_strip = STRIP $^
|
|
cmd_crosstools_strip = $(STRIP) $^; touch $@
|
|
--
|
|
2.20.1
|
|
|