kumquat-buildroot/package/sysvinit/0001-fix-libcrypt-test.patch
Joao Pinto c93805207e sysvinit: arm64 build fix
sysvinit was not able to be built for arm64 architectures.
The package patch was changed according to the suggestion of
Thomas Petazzoni.

Signed-off-by: Joao Pinto <jpinto@synopsys.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2015-12-17 23:48:02 +01:00

21 lines
619 B
Diff

Make the libcrypt test somewhat cross-compilation compliant
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Index: b/src/Makefile
===================================================================
--- a/src/Makefile
+++ b/src/Makefile
@@ -78,8 +78,9 @@ else
endif
# Additional libs for GNU libc.
-ifneq ($(wildcard /usr/lib*/libcrypt.a),)
- SULOGINLIBS += -lcrypt
+HAS_LIBCRYPT=$(shell f=`mktemp` && echo 'int main(void) {}' | $(CC) -o $$f -xc - -lcrypt >/dev/null 2>&1 && echo yes; rm -f $$f)
+ifeq ($(HAS_LIBCRYPT),yes)
+ SULOGINLIBS += -lcrypt
endif
all: $(BIN) $(SBIN) $(USRBIN)