102a93bdca
The CONFIG_UPDATE macro is no longer defined in package/gnuconfig/gnuconfig.mk, but instead in package/Makefile.autotools.in. It it also changed a little bit to take the directory of the package sources as argument, and the AUTOTARGETS infrastructure is updated to use this macro. [Peter: drop echo in CONFIG_UPDATE] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
46 lines
1.2 KiB
Diff
46 lines
1.2 KiB
Diff
--- config.sub
|
|
+++ config.sub
|
|
@@ -253,7 +253,7 @@ case $basic_machine in
|
|
| arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr | avr32 \
|
|
| bfin \
|
|
| c4x | clipper \
|
|
- | d10v | d30v | dlx | dsp16xx \
|
|
+ | d10v | d30v | dlx | dsp16xx | dvp \
|
|
| fido | fr30 | frv \
|
|
| h8300 | h8500 | hppa | hppa1.[01] | hppa2.0 | hppa2.0[nw] | hppa64 \
|
|
| i370 | i860 | i960 | ia64 \
|
|
@@ -773,6 +773,24 @@ case $basic_machine in
|
|
basic_machine=m68k-atari
|
|
os=-mint
|
|
;;
|
|
+ mipsEE* | ee | ps2)
|
|
+ basic_machine=mips64r5900el-scei
|
|
+ case $os in
|
|
+ -linux*)
|
|
+ ;;
|
|
+ *)
|
|
+ os=-elf
|
|
+ ;;
|
|
+ esac
|
|
+ ;;
|
|
+ iop)
|
|
+ basic_machine=mipsel-scei
|
|
+ os=-irx
|
|
+ ;;
|
|
+ dvp)
|
|
+ basic_machine=dvp-scei
|
|
+ os=-elf
|
|
+ ;;
|
|
mips3*-*)
|
|
basic_machine=`echo $basic_machine | sed -e 's/mips3/mips64/'`
|
|
;;
|
|
@@ -1325,7 +1343,7 @@ case $os in
|
|
| -os2* | -vos* | -palmos* | -uclinux* | -nucleus* \
|
|
| -morphos* | -superux* | -rtmk* | -rtmk-nova* | -windiss* \
|
|
| -powermax* | -dnix* | -nx6 | -nx7 | -sei* | -dragonfly* \
|
|
- | -skyos* | -haiku* | -rdos* | -toppers* | -drops* | -es*)
|
|
+ | -skyos* | -haiku* | -rdos* | -toppers* | -drops* | -es* | -irx*)
|
|
# Remember, each alternative MUST END IN *, to match a version number.
|
|
;;
|
|
-qnx*)
|