0d4133edfe
Until now, the gettext source code was being patched differently for the host and the target build, which is going to be incompatible with out-of-tree build. The difference is that the gettext tools could be disabled in the target build, but are always enabled on the host build. Therefore, this commit switches the gettext package to using proper patches against the relevant configure.ac and Makefile.am files. gettext is now being autoreconfigured. Configuration options are also passed for the host variant, in order to disable the build of a large number of things we don't care about. Finally, the two existing patches are renamed to include a number in their filename. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
26 lines
815 B
Diff
26 lines
815 B
Diff
gettext-runtime: use @SHELL@ for the SHELL variable definition
|
|
|
|
The gettext-runtime/Makefile.in uses an hardcoded SHELL = /bin/sh
|
|
variable. This causes problems at build time, because libtool is then
|
|
called with the 'sh' shell, which does not support the += construct
|
|
that the libtool script is using.
|
|
|
|
Instead, this Makefile.in should be definining SHELL = @SHELL@, just
|
|
like all other Makefile.in of gettext.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
|
|
Index: b/gettext-runtime/intl/Makefile.in
|
|
===================================================================
|
|
--- a/gettext-runtime/intl/Makefile.in
|
|
+++ b/gettext-runtime/intl/Makefile.in
|
|
@@ -17,7 +17,7 @@
|
|
PACKAGE = @PACKAGE@
|
|
VERSION = @VERSION@
|
|
|
|
-SHELL = /bin/sh
|
|
+SHELL = @SHELL@
|
|
|
|
srcdir = @srcdir@
|
|
top_srcdir = @top_srcdir@
|