476f5fc8f6
The major changes in terms of Buildroot packaging are: - Due to PEP488, Python no longer generates .pyc (unoptimized) and .pyo (optimized) byte-code files. Instead, it generates <foo>.pyc, <foo>.opt-1.pyc and <foo>.opt-2.pyc. Therefore, we removed the --disable-pyo-build option and kept only the --disable-pyc-build option, which completely disables building all .pyc files. In addition, since the optimized .opt-X.pyc files don't work if the corresponding un-optimized .pyc file is not present, we are for the moment unconditionally removing the optimized ones (keeping both the unoptimized and optimized ones doubles the required filesystem size!). So basically we preserve the behavior we had before this commit: BR2_PACKAGE_PYTHON3_PY_ONLY -> only *.py BR2_PACKAGE_PYTHON3_PYC_ONLY -> only non-optimized *.pyc BR2_PACKAGE_PYTHON3_PY_PYC -> both the *.py and non-optimized *.pyc To achieve this, the TARGET_FINALIZE_HOOKS are reworked: PYTHON3_REMOVE_PY_FILES is responsible for removing *.py files in the BR2_PACKAGE_PYTHON3_PYC_ONLY case. PYTHON3_REMOVE_PYC_FILES is responsible for removing *.pyc files in the BR2_PACKAGE_PYTHON3_PY_ONLY case. PYTHON3_REMOVE_OPTIMIZED_PYC_FILES is responsible for removing the optimized *.opt-1.pyc and *.opt-2.pyc files, which is done unconditionally. - The PEP3147 disabling patch had to be significantly reworked due to the code having changed heavily. The code was moved into a _bootstrap_external.py, which is a "frozen" Python module, i.e a module generated into a .h file at compile time using the _freeze_importlib program. - Due to the above, we now need to regenerate importlib.h at build time. Unfortunately, for the target Python _freeze_importlib is built for the target, so we can't run it on the build machine. To fix this, we copy the _freeze_importlib program from the host-python in $(HOST_DIR), and then patch the target python to use it. Since the same solution can be used for 'pgen', we do it, and avoid having to touch the graminit.{c,h} files. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: Samuel Martin <s.martin49@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
63 lines
2.0 KiB
Diff
63 lines
2.0 KiB
Diff
From 4f851142b8f3149d23654117621285df34ec768b Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Date: Wed, 23 Dec 2015 13:58:00 +0100
|
|
Subject: [PATCH] Support PGEN_FOR_BUILD and FREEZE_IMPORTLIB_FOR_BUILD
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
---
|
|
Makefile.pre.in | 10 ++++++++++
|
|
configure.ac | 3 +++
|
|
2 files changed, 13 insertions(+)
|
|
|
|
diff --git a/Makefile.pre.in b/Makefile.pre.in
|
|
index 2466615..fdf622d 100644
|
|
--- a/Makefile.pre.in
|
|
+++ b/Makefile.pre.in
|
|
@@ -712,10 +712,15 @@ Programs/_testembed: Programs/_testembed.o $(LIBRARY) $(LDLIBRARY) $(PY3LIBRARY)
|
|
############################################################################
|
|
# Importlib
|
|
|
|
+ifeq (@FREEZE_IMPORTLIB_FOR_BUILD@,)
|
|
Programs/_freeze_importlib.o: Programs/_freeze_importlib.c Makefile
|
|
|
|
Programs/_freeze_importlib: Programs/_freeze_importlib.o $(LIBRARY_OBJS_OMIT_FROZEN)
|
|
$(LINKCC) $(PY_LDFLAGS) -o $@ Programs/_freeze_importlib.o $(LIBRARY_OBJS_OMIT_FROZEN) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
|
|
+else
|
|
+Programs/_freeze_importlib: @FREEZE_IMPORTLIB_FOR_BUILD@
|
|
+ cp $^ $@
|
|
+endif
|
|
|
|
Python/importlib_external.h: $(srcdir)/Lib/importlib/_bootstrap_external.py Programs/_freeze_importlib
|
|
./Programs/_freeze_importlib \
|
|
@@ -789,8 +794,13 @@ $(GRAMMAR_H): $(GRAMMAR_INPUT) $(PGEN)
|
|
$(GRAMMAR_C): $(GRAMMAR_H)
|
|
touch $(GRAMMAR_C)
|
|
|
|
+ifeq (@PGEN_FOR_BUILD@,)
|
|
$(PGEN): $(PGENOBJS)
|
|
$(CC) $(OPT) $(PY_LDFLAGS) $(PGENOBJS) $(LIBS) -o $(PGEN)
|
|
+else
|
|
+$(PGEN): @PGEN_FOR_BUILD@
|
|
+ cp $^ $@
|
|
+endif
|
|
|
|
Parser/grammar.o: $(srcdir)/Parser/grammar.c \
|
|
$(srcdir)/Include/token.h \
|
|
diff --git a/configure.ac b/configure.ac
|
|
index c4c2353..750c232 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -79,6 +79,9 @@ else
|
|
fi
|
|
AC_SUBST(PYTHON_FOR_BUILD)
|
|
|
|
+AC_SUBST(PGEN_FOR_BUILD)
|
|
+AC_SUBST(FREEZE_IMPORTLIB_FOR_BUILD)
|
|
+
|
|
dnl Ensure that if prefix is specified, it does not end in a slash. If
|
|
dnl it does, we get path names containing '//' which is both ugly and
|
|
dnl can cause trouble.
|
|
--
|
|
2.6.4
|
|
|