8ef20378b7
tests/fp/fp-bench.c use fenv.h that is not always provided by the libc (uClibc). To workaround this issue, add an new meson option to disable tests while building Qemu. Fixes: http://autobuild.buildroot.net/results/53f5d8baa994d599b9da013ee643b82353366ec3/build-end.log Signed-off-by: Romain Naour <romain.naour@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
93 lines
2.7 KiB
Diff
93 lines
2.7 KiB
Diff
From c24f6cc8f847a4f90cd8fe0f94604862c5ac4a5e Mon Sep 17 00:00:00 2001
|
|
From: Romain Naour <romain.naour@gmail.com>
|
|
Date: Mon, 21 Dec 2020 22:12:14 +0100
|
|
Subject: [PATCH] meson: add tests option
|
|
|
|
tests/fp/fp-bench.c use fenv.h that is not always provided
|
|
by the libc (uClibc).
|
|
|
|
To workaround this issue, add an new meson option to
|
|
disable tests while building Qemu.
|
|
|
|
Fixes:
|
|
http://autobuild.buildroot.net/results/53f5d8baa994d599b9da013ee643b82353366ec3/build-end.log
|
|
|
|
Signed-off-by: Romain Naour <romain.naour@gmail.com>
|
|
---
|
|
configure | 7 +++++++
|
|
meson.build | 5 ++++-
|
|
meson_options.txt | 2 ++
|
|
3 files changed, 13 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/configure b/configure
|
|
index 18c26e0389..7cceae4418 100755
|
|
--- a/configure
|
|
+++ b/configure
|
|
@@ -449,6 +449,7 @@ meson=""
|
|
ninja=""
|
|
skip_meson=no
|
|
gettext=""
|
|
+tests="auto"
|
|
|
|
bogus_os="no"
|
|
malloc_trim="auto"
|
|
@@ -1525,6 +1526,10 @@ for opt do
|
|
;;
|
|
--disable-libdaxctl) libdaxctl=no
|
|
;;
|
|
+ --disable-tests) tests="disabled"
|
|
+ ;;
|
|
+ --enable-tests) tests="enabled"
|
|
+ ;;
|
|
*)
|
|
echo "ERROR: unknown option $opt"
|
|
echo "Try '$0 --help' for more information"
|
|
@@ -1850,6 +1855,7 @@ disabled with --disable-FEATURE, default is enabled if available:
|
|
xkbcommon xkbcommon support
|
|
rng-none dummy RNG, avoid using /dev/(u)random and getrandom()
|
|
libdaxctl libdaxctl support
|
|
+ tests build tests
|
|
|
|
NOTE: The object files are built at the place where configure is launched
|
|
EOF
|
|
@@ -7014,6 +7020,7 @@ NINJA=$ninja $meson setup \
|
|
-Diconv=$iconv -Dcurses=$curses -Dlibudev=$libudev\
|
|
-Ddocs=$docs -Dsphinx_build=$sphinx_build -Dinstall_blobs=$blobs \
|
|
-Dvhost_user_blk_server=$vhost_user_blk_server \
|
|
+ -Dtests=$tests \
|
|
$cross_arg \
|
|
"$PWD" "$source_path"
|
|
|
|
diff --git a/meson.build b/meson.build
|
|
index e3386196ba..7f4efdc347 100644
|
|
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -1944,7 +1944,10 @@ subdir('scripts')
|
|
subdir('tools')
|
|
subdir('pc-bios')
|
|
subdir('docs')
|
|
-subdir('tests')
|
|
+if get_option('tests').enabled()
|
|
+ subdir('tests')
|
|
+endif
|
|
+
|
|
if 'CONFIG_GTK' in config_host
|
|
subdir('po')
|
|
endif
|
|
diff --git a/meson_options.txt b/meson_options.txt
|
|
index f6f64785fe..81bffbfe87 100644
|
|
--- a/meson_options.txt
|
|
+++ b/meson_options.txt
|
|
@@ -66,6 +66,8 @@ option('virtiofsd', type: 'feature', value: 'auto',
|
|
description: 'build virtiofs daemon (virtiofsd)')
|
|
option('vhost_user_blk_server', type: 'feature', value: 'auto',
|
|
description: 'build vhost-user-blk server')
|
|
+option('tests', type : 'feature', value : 'auto',
|
|
+ description: 'Tests build support')
|
|
|
|
option('capstone', type: 'combo', value: 'auto',
|
|
choices: ['disabled', 'enabled', 'auto', 'system', 'internal'],
|
|
--
|
|
2.29.2
|
|
|