f40bb40075
Refactored patch 0002, added support for Intel SSE2.
Changelog:
b363e01e6b
/#diff-2
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
56 lines
1.9 KiB
Diff
56 lines
1.9 KiB
Diff
From 473fdecd9a580b45251480b8ccbbb1927c598310 Mon Sep 17 00:00:00 2001
|
|
From: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
|
Date: Thu, 26 May 2016 16:27:13 -0300
|
|
Subject: [PATCH] Don't append prefix to symbol names in version script
|
|
|
|
Even if Blackfin GNU toolchain add prefix '_' to all symbols,
|
|
symbol prefix is not accepted in the link flag --version-script.
|
|
Don't append prefix in the symbols in the version script file.
|
|
|
|
Original patch by: Sonic Zhang <sonic.zhang@analog.com>
|
|
|
|
[Gustavo: update for 1.6.22]
|
|
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
|
|
|
[Julien: update for 1.6.25]
|
|
Signed-off-by: Julien Boibessot <julien.boibessot@armadeus.com>
|
|
|
|
[Bernd: update for 1.6.29]
|
|
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
|
|
|
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
|
---
|
|
Makefile.am | 2 +-
|
|
Makefile.in | 2 +-
|
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/Makefile.am b/Makefile.am
|
|
index 3430dca..db6a7a2 100644
|
|
--- a/Makefile.am
|
|
+++ b/Makefile.am
|
|
@@ -245,7 +245,7 @@ contrib/tools/pngfix.o: pnglibconf.h
|
|
# interfering with the symbol file format.
|
|
SYMBOL_CFLAGS = -DPNGLIB_LIBNAME='PNG@PNGLIB_MAJOR@@PNGLIB_MINOR@_0'\
|
|
-DPNGLIB_VERSION='@PNGLIB_VERSION@'\
|
|
- -DSYMBOL_PREFIX='$(SYMBOL_PREFIX)'\
|
|
+ -DSYMBOL_PREFIX=''\
|
|
-DPNG_NO_USE_READ_MACROS -DPNG_BUILDING_SYMBOL_TABLE
|
|
|
|
if DO_PNG_PREFIX
|
|
diff --git a/Makefile.in b/Makefile.in
|
|
index 4e67782..5f468d9 100644
|
|
--- a/Makefile.in
|
|
+++ b/Makefile.in
|
|
@@ -766,7 +766,7 @@ SUFFIXES = .chk .out
|
|
# interfering with the symbol file format.
|
|
SYMBOL_CFLAGS = -DPNGLIB_LIBNAME='PNG@PNGLIB_MAJOR@@PNGLIB_MINOR@_0' \
|
|
-DPNGLIB_VERSION='@PNGLIB_VERSION@' \
|
|
- -DSYMBOL_PREFIX='$(SYMBOL_PREFIX)' -DPNG_NO_USE_READ_MACROS \
|
|
+ -DSYMBOL_PREFIX='' -DPNG_NO_USE_READ_MACROS \
|
|
-DPNG_BUILDING_SYMBOL_TABLE $(am__append_9)
|
|
|
|
# EXT_LIST is a list of the possibly library directory extensions, this exists
|
|
--
|
|
2.7.3
|
|
|