66d7d3bec3
Fix libexecinfo workaround to avoid the following ffmpeg build failure
with BR2_PACKAGE_RPI_USERLAND raised on uclibc and musl since commit
bc4cc27705
:
/home/giuliobenetti/autobuild/run/instance-3/output-1/host/bin/arm-linux-gcc --sysroot=/home/giuliobenetti/autobuild/run/instance-3/output-1/host/arm-buildroot-linux-uclibcgnueabi/sysroot -mcpu=arm926ej-s -Wl,--as-needed -Wl,-z,noexecstack -o /tmp/ffconf.5K0cMIh3/test /tmp/ffconf.5K0cMIh3/test.o -lmmal_core -lmmal_util -lmmal_vc_client -lbcm_host -latomic
/home/giuliobenetti/autobuild/run/instance-3/output-1/host/opt/ext-toolchain/bin/../lib/gcc/arm-buildroot-linux-uclibcgnueabi/10.3.0/../../../../arm-buildroot-linux-uclibcgnueabi/bin/ld: /home/giuliobenetti/autobuild/run/instance-3/output-1/host/arm-buildroot-linux-uclibcgnueabi/sysroot/usr/lib/libvcos.so: undefined reference to `backtrace_symbols'
[...]
ERROR: mmal not found
Fixes:
- http://autobuild.buildroot.org/results/64d21872d25fef35b72106133ed2aed300f52f2f
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
46 lines
1.7 KiB
Diff
46 lines
1.7 KiB
Diff
From 220c37b496f5c883bbfa955ee7fee471e41c34d4 Mon Sep 17 00:00:00 2001
|
|
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
Date: Fri, 25 Feb 2022 19:21:06 +0100
|
|
Subject: [PATCH] interface/vcos/pthreads/CMakeLists.txt: fix build with
|
|
libexecinfo
|
|
|
|
interface/vcos/glibc/vcos_backtrace.c uses execinfo.h which can be
|
|
provided by libexecinfo on uclibc or musl so link with it if needed to
|
|
avoid the following build failure:
|
|
|
|
/home/peko/autobuild/instance-1/output-1/host/opt/ext-toolchain/bin/../lib/gcc/arm-buildroot-linux-uclibcgnueabi/10.3.0/../../../../arm-buildroot-linux-uclibcgnueabi/bin/ld: ../../build/lib/libvcos.so: undefined reference to `backtrace_symbols'
|
|
|
|
Fixes:
|
|
- http://autobuild.buildroot.org/results/93d3b8cc2ac5dfa9d4b44946c0b4d8171e8f52a1
|
|
|
|
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
[Upstream status: https://github.com/raspberrypi/userland/pull/719]
|
|
---
|
|
interface/vcos/pthreads/CMakeLists.txt | 6 ++++--
|
|
1 file changed, 4 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/interface/vcos/pthreads/CMakeLists.txt b/interface/vcos/pthreads/CMakeLists.txt
|
|
index 1d81ca3..43aca03 100644
|
|
--- a/interface/vcos/pthreads/CMakeLists.txt
|
|
+++ b/interface/vcos/pthreads/CMakeLists.txt
|
|
@@ -33,12 +33,14 @@ set (SOURCES
|
|
../generic/vcos_generic_blockpool.c
|
|
)
|
|
|
|
+find_library (EXECINFO_LIBRARY execinfo)
|
|
+
|
|
if (VCOS_PTHREADS_BUILD_SHARED)
|
|
add_library (vcos SHARED ${SOURCES})
|
|
- target_link_libraries (vcos pthread dl rt)
|
|
+ target_link_libraries (vcos pthread dl rt ${EXECINFO_LIBRARY})
|
|
else ()
|
|
add_library (vcos ${SOURCES})
|
|
- target_link_libraries (vcos pthread rt)
|
|
+ target_link_libraries (vcos pthread rt ${EXECINFO_LIBRARY})
|
|
endif ()
|
|
|
|
|
|
--
|
|
2.35.1
|
|
|