00e7d119ec
allow usage of amcodec if kodi is built and libamcodec is selected Signed-off-by: Dagg Stompler <daggs@gmx.com> [Thomas: fix KODI_INCLUDES definition in RPi case, fix indentation.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
39 lines
1.3 KiB
Diff
39 lines
1.3 KiB
Diff
commit 4bbb21aa5cee6b2f40759aa8b1bd65246a237f79
|
|
Author: Alex Deryskyba <alex@codesnake.com>
|
|
Date: Wed May 4 01:38:27 2016 +0200
|
|
|
|
[aml] Fix includes in amcodec/codec.h to make them relative
|
|
|
|
[Taken from upstream commit
|
|
https://github.com/xbmc/xbmc/commit/4bbb21aa5cee6b2f40759aa8b1bd65246a237f79.]
|
|
Signed-off-by: Dagg Stompler <daggs@gmx.com>
|
|
|
|
diff --git a/tools/depends/target/libamplayer/libamplayer/include/amcodec/codec.h b/tools/depends/target/libamplayer/libamplayer/include/amcodec/codec.h
|
|
index 187d4d5..632c24e 100644
|
|
--- a/tools/depends/target/libamplayer/libamplayer/include/amcodec/codec.h
|
|
+++ b/tools/depends/target/libamplayer/libamplayer/include/amcodec/codec.h
|
|
@@ -12,8 +12,8 @@
|
|
#ifndef CODEC_CTRL_H_
|
|
#define CODEC_CTRL_H_
|
|
|
|
-#include <codec_type.h>
|
|
-#include <codec_error.h>
|
|
+#include "codec_type.h"
|
|
+#include "codec_error.h"
|
|
|
|
|
|
int codec_init(codec_para_t *);
|
|
diff --git a/xbmc/cores/dvdplayer/DVDCodecs/Video/Makefile.in b/xbmc/cores/dvdplayer/DVDCodecs/Video/Makefile.in
|
|
index a1a3447..1bf5a89 100644
|
|
--- a/xbmc/cores/dvdplayer/DVDCodecs/Video/Makefile.in
|
|
+++ b/xbmc/cores/dvdplayer/DVDCodecs/Video/Makefile.in
|
|
@@ -24,8 +24,6 @@ endif
|
|
ifeq (@USE_LIBAMCODEC@,1)
|
|
SRCS += AMLCodec.cpp
|
|
SRCS += DVDVideoCodecAmlogic.cpp
|
|
-INCLUDES += -I$(prefix)/include/amcodec
|
|
-INCLUDES += -I$(prefix)/include/amplayer
|
|
endif
|
|
|
|
ifeq (@USE_ANDROID@,1)
|